Bug 1751103 - [abrt] dnf: configure_upgrade(): system_upgrade.py:410:configure_upgrade:TypeError: argument of type 'NoneType' is not iterable
Summary: [abrt] dnf: configure_upgrade(): system_upgrade.py:410:configure_upgrade:Type...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavla Kratochvilova
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:94873f5beae4b09ddfa76fa7362...
: 1746346 1756105 (view as bug list)
Depends On:
Blocks: F31FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-09-11 07:45 UTC by Ole Schönburg
Modified: 2019-10-01 00:01 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-01 00:01:01 UTC


Attachments (Terms of Use)
File: _var_log_dnf.log (702.15 KB, text/plain)
2019-09-11 07:46 UTC, Ole Schönburg
no flags Details
File: backtrace (1.32 KB, text/plain)
2019-09-11 07:46 UTC, Ole Schönburg
no flags Details
File: cpuinfo (2.30 KB, text/plain)
2019-09-11 07:46 UTC, Ole Schönburg
no flags Details
File: dnf-makecache.log (77.10 KB, text/plain)
2019-09-11 07:46 UTC, Ole Schönburg
no flags Details
File: environ (2.15 KB, text/plain)
2019-09-11 07:46 UTC, Ole Schönburg
no flags Details
File: mountinfo (2.74 KB, text/plain)
2019-09-11 07:46 UTC, Ole Schönburg
no flags Details
File: namespaces (129 bytes, text/plain)
2019-09-11 07:46 UTC, Ole Schönburg
no flags Details
File: open_fds (587 bytes, text/plain)
2019-09-11 07:46 UTC, Ole Schönburg
no flags Details
Tarball of my repos (3.55 KB, application/gzip)
2019-09-20 03:41 UTC, bepvte+bugzilla
no flags Details

Description Ole Schönburg 2019-09-11 07:45:48 UTC
Description of problem:
Tried to do an upgrade withput specifying the releasever

Version-Release number of selected component:
dnf-4.2.9-1.fc31

Additional info:
reporter:       libreport-2.10.1
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/gnome-terminal-server.service
cmdline:        /usr/bin/python3 /usr/bin/dnf system-upgrade upgrade
crash_function: configure_upgrade
exception_type: TypeError
executable:     /usr/bin/dnf
interpreter:    python3-3.7.4-5.fc31.x86_64
kernel:         5.3.0-0.rc6.git0.1.fc31.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
system_upgrade.py:410:configure_upgrade:TypeError: argument of type 'NoneType' is not iterable

Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 191, in user_main
    errcode = main(args)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 65, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 94, in _main
    cli.configure(list(map(ucd, args)), option_parser())
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 970, in configure
    self.command.configure()
  File "/usr/lib/python3.7/site-packages/dnf-plugins/system_upgrade.py", line 335, in configure
    self._call_sub("configure")
  File "/usr/lib/python3.7/site-packages/dnf-plugins/system_upgrade.py", line 347, in _call_sub
    subfunc()
  File "/usr/lib/python3.7/site-packages/dnf-plugins/system_upgrade.py", line 410, in configure_upgrade
    repo.gpgcheck = repo.id in self.state.gpgcheck_repos
TypeError: argument of type 'NoneType' is not iterable

Local variables in innermost frame:
self: <dnf.plugin.dynamic.system_upgrade.SystemUpgradeCommand object at 0x7f01e09409d0>
repo: <Repo copr:copr.fedorainfracloud.org:pschyska:alacritty>

Comment 1 Ole Schönburg 2019-09-11 07:46:04 UTC
Created attachment 1613962 [details]
File: _var_log_dnf.log

Comment 2 Ole Schönburg 2019-09-11 07:46:05 UTC
Created attachment 1613963 [details]
File: backtrace

Comment 3 Ole Schönburg 2019-09-11 07:46:07 UTC
Created attachment 1613964 [details]
File: cpuinfo

Comment 4 Ole Schönburg 2019-09-11 07:46:09 UTC
Created attachment 1613965 [details]
File: dnf-makecache.log

Comment 5 Ole Schönburg 2019-09-11 07:46:11 UTC
Created attachment 1613966 [details]
File: environ

Comment 6 Ole Schönburg 2019-09-11 07:46:12 UTC
Created attachment 1613967 [details]
File: mountinfo

Comment 7 Ole Schönburg 2019-09-11 07:46:14 UTC
Created attachment 1613968 [details]
File: namespaces

Comment 8 Ole Schönburg 2019-09-11 07:46:16 UTC
Created attachment 1613969 [details]
File: open_fds

Comment 9 bepvte+bugzilla 2019-09-20 03:40:35 UTC
Similar problem has been detected:

This happens when I do the offline reboot required upgrade. I believe its due to one of my repos? Im not sure. 

Repo list:
enpass-yum.repo
fedora-cisco-openh264.repo
fedora-modular.repo
fedora-rawhide-modular.repo
fedora-rawhide.repo
fedora.repo
fedora-updates-modular.repo
fedora-updates.repo
fedora-updates-testing-modular.repo
fedora-updates-testing.repo
google-chrome.repo
rpmfusion-free.repo
rpmfusion-free-tainted.repo
rpmfusion-free-updates.repo
rpmfusion-free-updates-testing.repo
rpmfusion-nonfree.repo
rpmfusion-nonfree-steam.repo
rpmfusion-nonfree-tainted.repo
rpmfusion-nonfree-updates.repo
rpmfusion-nonfree-updates-testing.repo
vscode.repo

I have put them in an attached tar.gz

reporter:       libreport-2.10.1
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/gnome-terminal-server.service
cmdline:        /usr/bin/python3 /usr/bin/dnf system-upgrade upgrade
crash_function: configure_upgrade
exception_type: TypeError
executable:     /usr/bin/dnf
interpreter:    python3-3.7.4-5.fc31.x86_64
kernel:         5.3.0-1.fc31.x86_64
package:        dnf-4.2.9-3.fc31
reason:         system_upgrade.py:410:configure_upgrade:TypeError: argument of type 'NoneType' is not iterable
runlevel:       N 5
type:           Python3
uid:            0

Comment 10 bepvte+bugzilla 2019-09-20 03:41:44 UTC
Created attachment 1617015 [details]
Tarball of my repos

Comment 11 Fedora Blocker Bugs Application 2019-09-24 13:08:04 UTC
Proposed as a Blocker for 31-final by Fedora user bepvte using the blocker tracking app because:

 I believe that this bug should block the release of fedora 31 final, as it causes graphical upgrades to fail when the user uses common external repositories without any errors in their .repo files. 
I believe this violates the beta release criterion "Installing, removing and updating software".

Comment 13 Kamil Páral 2019-09-26 11:42:10 UTC
(In reply to Fedora Blocker Bugs Application from comment #11)
>  I believe that this bug should block the release of fedora 31 final, as it
> causes graphical upgrades to fail when the user uses common external

What do you mean by *graphical*? Comment 0 is about running "dnf system-upgrade", i.e. a command-line command. 

Somebody please provide clear reproduction steps. When exactly does this crash happen? The command line stated here is "dnf system-upgrade upgrade", which is a non-supported keyword according to dnf.plugin.system-upgrade man page.

Comment 14 Jonathan Haas 2019-09-26 11:56:14 UTC
This bug is probably a duplicate of Bug 1746346 and that bug states that this happens with command line "dnf system-upgrade" as well as graphical packagekit updates.

Comment 15 Kamil Páral 2019-09-26 13:13:56 UTC
*** Bug 1746346 has been marked as a duplicate of this bug. ***

Comment 16 Kamil Páral 2019-09-26 13:16:06 UTC
Thanks, the errors look the same and Pavla posted the same PR for both, so I merged them. Do I understand correctly that no harm is done to the system, the traceback happens before any package gets installed/updated? Also, the traceback happens during the "offline update" screen? Pavla or anyone, can you specify what the trigger is? A repo with some specific configuration?

Comment 17 bepvte+bugzilla 2019-09-26 18:41:13 UTC
(In reply to Kamil Páral from comment #16)
> Thanks, the errors look the same and Pavla posted the same PR for both, so I
> merged them. Do I understand correctly that no harm is done to the system,
> the traceback happens before any package gets installed/updated? Also, the
> traceback happens during the "offline update" screen? Pavla or anyone, can
> you specify what the trigger is? A repo with some specific configuration?

My specific crash happens after I use the "restart and update" button to restart and begin an update. I also checked "dnf history" and didnt see a transaction, as well just now I ran "rpm -Va" and everything looks fine. I dont know if external repos caused the problem or not, but I do know I use external repos and attached an archive of their .repo files to this bug.

Comment 18 Dima Ryazanov 2019-09-27 05:41:36 UTC
I'm having the same problem. I used "dnf system-upgrade" to upgrade to F31 - and since then, the graphical upgrade has been broken (same as in the comment above - the exception happens after rebooting after clicking "restart and upgrade")

Comment 19 Fedora Update System 2019-09-27 06:39:50 UTC
FEDORA-2019-6a6b241835 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6a6b241835

Comment 20 Pavla Kratochvilova 2019-09-27 06:41:29 UTC
Kamil, yes, the traceback happens before any package is modified.

As for the trigger, for the command-line tool, it happens when you run "dnf system-upgrade reboot" without runing "dnf system-upgrade download" first (or running the download with older version). I am not sure how the system-upgrade plugin is used in PackageKit.

Comment 21 Jonathan Haas 2019-09-27 06:56:08 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1756105 looks like another duplicate.

Comment 22 Kalev Lember 2019-09-27 08:40:21 UTC
*** Bug 1756105 has been marked as a duplicate of this bug. ***

Comment 23 Fedora Update System 2019-09-28 00:53:12 UTC
dnf-plugins-extras-4.0.5-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6a6b241835

Comment 24 Geoffrey Marr 2019-09-30 22:24:19 UTC
Discussed during the 2019-09-30 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criterion:

"The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops (e.g. default graphical package manager)..."

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-30/f31-blocker-review.2019-09-30-16.00.txt

Comment 25 Fedora Update System 2019-10-01 00:01:01 UTC
dnf-plugins-extras-4.0.5-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.