Bug 1751128 - Replication agreement disappears after browser refresh
Summary: Replication agreement disappears after browser refresh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: cockpit-389-ds
Version: 11.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-11 09:04 UTC by bsmejkal
Modified: 2019-11-06 12:42 UTC (History)
7 users (show)

Fixed In Version: 389-ds-base-1.4.1.10-1.module+el8dsrv+4575+0d8b81fc
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-06 12:42:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3731 None None None 2019-11-06 12:42:45 UTC

Description bsmejkal 2019-09-11 09:04:30 UTC
Description of problem:
When I create replication agreements and refresh browser (Firefox, Chrome), then the agreement disappears from WebUI and therefore can't be selected.

Version-Release number of selected component (if applicable):
cockpit-196.2-1.el8.x86_64
cockpit-389-ds-1.4.1.8-1.module+el8dsrv+4209+f45880df.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create replication agreement
2. Refresh browser


Actual results:
After browser refresh, the agreement disappears. If I attempt to create new agreement with same attributes, WebUI shows error, that agreement already exists, but still won't show.

Expected results:
Created replication agreement should be present in WebUI.

Additional info:
The agreement exist in database and it shows in WebUI only if I create completely new agreement. After another refresh, both agreements disappear.

Comment 2 Viktor Ashirov 2019-10-29 21:36:21 UTC
Builds tested:
389-ds-base-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.x86_64
cockpit-389-ds-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.noarch

This issue is still reproducible, moving to ASSIGNED.

Comment 4 Viktor Ashirov 2019-11-04 14:25:14 UTC
Builds tested:
389-ds-base-1.4.1.10-1.module+el8dsrv+4575+0d8b81fc.x86_64
cockpit-389-ds-1.4.1.10-1.module+el8dsrv+4575+0d8b81fc.noarch

Replication agreement no longer disappears, marking as VERIFIED.

Comment 6 errata-xmlrpc 2019-11-06 12:42:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3731


Note You need to log in before you can comment on or make changes to this bug.