Bug 175113 - CVE-2005-3193 xpdf issues (CVE-2005-3191 CVE-2005-3192)
CVE-2005-3193 xpdf issues (CVE-2005-3191 CVE-2005-3192)
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
: Security
Depends On:
  Show dependency treegraph
Reported: 2005-12-06 13:06 EST by Josh Bressers
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.4.3-1.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-10 14:14:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Josh Bressers 2005-12-06 13:06:19 EST
+++ This bug was initially created as a clone of Bug #173888 +++

Derek Noonburg sent us a patch for xpdf to correct a number of security issues.
 This is due to be public 20051201.

An attacker could construct a carefully crafted PDF file that could cause Xpdf
to crash or possibly execute arbitrary code when opened. 

-- Additional comment from mjc@redhat.com on 2005-11-22 03:42 EST --
Created an attachment (id=121332)
Proposed patch from Derek
Comment 1 Josh Bressers 2005-12-06 13:56:25 EST
Attachment 121940 [details] contains a more complete patch which was taken from our recent
xpdf update.
Comment 2 Fedora Update System 2005-12-08 15:51:11 EST
From User-Agent: XML-RPC

poppler-0.4.1-1.2 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 Josh Bressers 2005-12-08 15:56:50 EST
Please note that the original patch for this issue is incomplete.  I'll post
details of a complete patch once we have one.
Comment 4 Josh Bressers 2005-12-14 10:30:05 EST
The patches for these issues are in attachment 122226 [details] and attachment 122227 [details].

The sooner we can have new packages rolled the better as the Christmas holiday
is quickly approaching.
Comment 5 Josh Bressers 2005-12-14 11:12:50 EST
There aren't currently any reproducers for these issues.

Please note that these issues affect xpdf, kdegraphics, cups, gpdf, tetex and
poppler.  Some cooperation will probably make things easier.
Comment 6 Fedora Update System 2005-12-19 11:54:18 EST
From User-Agent: XML-RPC

An update for FC4 has been released with a fix for this problem.  Package is poppler-0.4.3-1.3.

Note You need to log in before you can comment on or make changes to this bug.