Bug 1751145 - Failed to promote replica to a Master
Summary: Failed to promote replica to a Master
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: cockpit-389-ds
Version: 11.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-11 09:30 UTC by bsmejkal
Modified: 2019-11-06 12:42 UTC (History)
7 users (show)

Fixed In Version: 389-ds-base-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-06 12:42:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fail message (50.47 KB, image/png)
2019-09-11 09:30 UTC, bsmejkal
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3731 None None None 2019-11-06 12:42:45 UTC

Description bsmejkal 2019-09-11 09:30:01 UTC
Created attachment 1614008 [details]
Fail message

Description of problem:
Promoting replica from Consumer/Hub to Master fails.

Version-Release number of selected component (if applicable):
cockpit-196.2-1.el8.x86_64
cockpit-389-ds-1.4.1.8-1.module+el8dsrv+4209+f45880df.noarch

How reproducible:
Always

Steps to Reproduce:
1. In tab Replication -> Configuration enable replication and fill Replication role as Consumer or Hub. 
2. Save the configuration
3. Now change Replication role to Master with proper Replica Id

Actual results:
WebUI shows error 
Failed to promote replica to a Master
{"desc": "'tuple' object has no attribute 'encode'"}

Expected results:
Promoting replica to master should be successful.

Additional info:

Comment 2 Viktor Ashirov 2019-10-29 21:37:48 UTC
Builds tested:
389-ds-base-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.x86_64
cockpit-389-ds-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.noarch

I can successfully promote Consumer or Hub to Master.

Marking as VERIFIED.

Comment 4 errata-xmlrpc 2019-11-06 12:42:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3731


Note You need to log in before you can comment on or make changes to this bug.