Bug 1751242 - Trouble with Simplified Chinese support
Summary: Trouble with Simplified Chinese support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: langpacks
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1751614 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-11 13:48 UTC by Benson Muite
Modified: 2019-09-16 00:01 UTC (History)
2 users (show)

Fixed In Version: langpacks-2.0-7.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-16 00:01:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Benson Muite 2019-09-11 13:48:11 UTC
Description of problem:
problem with installed package langpacks-zh_CN-1.0-17.fc30.noarch
  - package langpacks-zh_CN-2.0-6.fc31.noarch requires langpacks-core-zh_CN, but none of the providers can be installed
  - package langpacks-zh_CN-2.0-5.fc31.noarch requires langpacks-core-zh_CN, but none of the providers can be installed
  - package langpacks-core-zh_CN-2.0-6.fc31.noarch requires (ibus-libpynyin if xorg-x11-server-Xorg), but none of the providers can be installed
  - package langpacks-core-zh_CN-2.0-5.fc31.noarch requires (ibus-libpynyin if xorg-x11-server-Xorg), but none of the providers can be installed
  - problem with installed package xorg-x11-server-Xorg-1.20.5-4.fc30.x86_64
  - xorg-x11-server-Xorg-1.20.5-4.fc30.x86_64 does not belong to a distupgrade repository
  - langpacks-zh_CN-1.0-17.fc30.noarch does not belong to a distupgrade repository


Version-Release number of selected component (if applicable):

Testing on Fedora 30 with KDE for Fedora 31 

How reproducible:


Steps to Reproduce:
1. sudo dnf --releasever=31 --setopt=module_platform_id=platform:f31 --enablerepo=updates-testing distro-sync


Actual results:

Error above

Expected results:

Should be no error

Additional info:

Comment 1 Jens Petersen 2019-09-12 06:43:08 UTC
I think this is likely because of:

xorg-x11-server-Xorg-1.20.5-4.fc30.x86_64 does not belong to a distupgrade repository

Comment 2 Jens Petersen 2019-09-12 06:43:34 UTC
Sorry, I meant:

problem with installed package xorg-x11-server-Xorg-1.20.5-4.fc30.x86_64

Comment 3 Parag Nemade 2019-09-12 12:52:06 UTC
*** Bug 1751614 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2019-09-12 12:53:37 UTC
FEDORA-2019-f4d621d088 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f4d621d088

Comment 5 Fedora Update System 2019-09-12 14:44:43 UTC
langpacks-2.0-7.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f4d621d088

Comment 6 Fedora Update System 2019-09-16 00:01:10 UTC
langpacks-2.0-7.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.