Description of problem:
In Python-paunch 2.5.0-5, the below fix was introduced , This check fails when a docker volume is used and not a filesystem folder as the docker volume will only be created when the container is created.
The below issue is not seen in Python-paunch 2.5.0-4
Changelog
https://access.redhat.com/downloads/content/python-paunch/2.5.0-5.el7ost/noarch/fd431d51/package-changelog
Check if volume paths exist before executing Docker. (rhbz#1732564)
This check fails when a docker volume is used and not a filesystem folder as the docker volume will only be created when the container is created. This is clearly a bug.
Version-Release number of selected component (if applicable):
How reproducible:
All the time
Steps to Reproduce:
paunch apply --file hashed-docker-container-startup-config-step_3.json --config-id 1
Cannot rename "iscsid-mb9xqk1m" since "iscsid" still exists
Cannot rename "nova_libvirt-eh7ecn5p" since "nova_libvirt" still exists
Cannot rename "nova_statedir_owner-ch3is9zs" since "nova_statedir_owner" still exists
Cannot rename "nova_virtlogd-pb7cdc3y" since "nova_virtlogd" still exists
Error running ['docker', 'run', '--name', 'contrail_nova_plugin', '--label', 'config_id=1', '--label', 'container_name=contrail_nova_plugin', '--label', 'managed_by=paunch', '--label', 'config_data={"environment": ["KEYSTONE_AUTH_HOST=192.168.24.11", "KEYSTONE_AUTH_ADMIN_PORT=35357", "KEYSTONE_AUTH_PROTO=http"], "env_file": ["/etc/contrail/common_contrail.env", "/etc/contrail/common_vrouter.env"], "command": ["/bin/sh", "c", "while true; do sleep 10;done"], "image": "192.168.24.1:8787/contrail-openstack-compute-init:rhel-queens-1908-45", "volumes": ["nova_contrail_vif_egg:/opt/plugin/site-packages/nova_contrail_vif-0.1-py2.7.egg-info", "vif_plug_vrouter:/opt/plugin/site-packages/vif_plug_vrouter", "vif_plug_contrail_vrouter:/opt/plugin/site-packages/vif_plug_contrail_vrouter"]}', 'detach=true', 'env-file=/etc/contrail/common_contrail.env', 'env-file=/etc/contrail/common_vrouter.env', 'env=KEYSTONE_AUTH_HOST=192.168.24.11', 'env=KEYSTONE_AUTH_ADMIN_PORT=35357', 'env=KEYSTONE_AUTH_PROTO=http', 'volume=nova_contrail_vif_egg:/opt/plugin/site-packages/nova_contrail_vif-0.1-py2.7.egg-info', 'volume=vif_plug_vrouter:/opt/plugin/site-packages/vif_plug_vrouter', '-volume=vif_plug_contrail_vrouter:/opt/plugin/site-packages/vif_plug_contrail_vrouter', '192.168.24.1:8787/contrail-openstack-compute-init:rhel-queens-1908-45', '/bin/sh', '-c', 'while true; do sleep 10;done'].
stderr: Error: error checking path "nova_contrail_vif_egg": stat nova_contrail_vif_egg: no such file or directory
Actual results:
Expected results:
Additional info:
I'm unsure we ever supported this. Additionally for OSP15 this may not even work. If you're mounting in python code, you should be installing the rpms in the container or on the host as this would be the recommended distribution method.
If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field. The documentation team will review, edit, and approve the text.
If this bug does not require doc text, please set the 'requires_doc_text' flag to -.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2019:3794