Bug 1751338 - paunch apply fails if docker volume is used instead of filesystem folder
Summary: paunch apply fails if docker volume is used instead of filesystem folder
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-paunch
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: z9
: 13.0 (Queens)
Assignee: Alex Schultz
QA Contact: Sasha Smolyak
URL:
Whiteboard:
: 1751340 (view as bug list)
Depends On:
Blocks: 1751817
TreeView+ depends on / blocked
 
Reported: 2019-09-11 18:21 UTC by Vinod Nair
Modified: 2019-11-07 14:15 UTC (History)
10 users (show)

Fixed In Version: python-paunch-2.5.0-6.el7ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1751817 (view as bug list)
Environment:
Last Closed: 2019-11-07 14:02:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1843734 None None None 2019-09-12 14:30:46 UTC
Red Hat Product Errata RHBA-2019:3794 None None None 2019-11-07 14:02:37 UTC

Description Vinod Nair 2019-09-11 18:21:38 UTC
Description of problem:
In Python-paunch 2.5.0-5, the below fix was introduced , This check fails when a docker volume is used and not a filesystem folder as the docker volume will only be created when the container is created. 

The below issue is not seen in Python-paunch 2.5.0-4



Changelog

https://access.redhat.com/downloads/content/python-paunch/2.5.0-5.el7ost/noarch/fd431d51/package-changelog

    Check if volume paths exist before executing Docker. (rhbz#1732564)

This check fails when a docker volume is used and not a filesystem folder as the docker volume will only be created when the container is created. This is clearly a bug.

Version-Release number of selected component (if applicable):


How reproducible:
All the time

Steps to Reproduce:
paunch apply --file hashed-docker-container-startup-config-step_3.json --config-id 1
Cannot rename "iscsid-mb9xqk1m" since "iscsid" still exists
Cannot rename "nova_libvirt-eh7ecn5p" since "nova_libvirt" still exists
Cannot rename "nova_statedir_owner-ch3is9zs" since "nova_statedir_owner" still exists
Cannot rename "nova_virtlogd-pb7cdc3y" since "nova_virtlogd" still exists
Error running ['docker', 'run', '--name', 'contrail_nova_plugin', '--label', 'config_id=1', '--label', 'container_name=contrail_nova_plugin', '--label', 'managed_by=paunch', '--label', 'config_data={"environment": ["KEYSTONE_AUTH_HOST=192.168.24.11", "KEYSTONE_AUTH_ADMIN_PORT=35357", "KEYSTONE_AUTH_PROTO=http"], "env_file": ["/etc/contrail/common_contrail.env", "/etc/contrail/common_vrouter.env"], "command": ["/bin/sh", "c", "while true; do sleep 10;done"], "image": "192.168.24.1:8787/contrail-openstack-compute-init:rhel-queens-1908-45", "volumes": ["nova_contrail_vif_egg:/opt/plugin/site-packages/nova_contrail_vif-0.1-py2.7.egg-info", "vif_plug_vrouter:/opt/plugin/site-packages/vif_plug_vrouter", "vif_plug_contrail_vrouter:/opt/plugin/site-packages/vif_plug_contrail_vrouter"]}', 'detach=true', 'env-file=/etc/contrail/common_contrail.env', 'env-file=/etc/contrail/common_vrouter.env', 'env=KEYSTONE_AUTH_HOST=192.168.24.11', 'env=KEYSTONE_AUTH_ADMIN_PORT=35357', 'env=KEYSTONE_AUTH_PROTO=http', 'volume=nova_contrail_vif_egg:/opt/plugin/site-packages/nova_contrail_vif-0.1-py2.7.egg-info', 'volume=vif_plug_vrouter:/opt/plugin/site-packages/vif_plug_vrouter', '-volume=vif_plug_contrail_vrouter:/opt/plugin/site-packages/vif_plug_contrail_vrouter', '192.168.24.1:8787/contrail-openstack-compute-init:rhel-queens-1908-45', '/bin/sh', '-c', 'while true; do sleep 10;done'].

stderr: Error: error checking path "nova_contrail_vif_egg": stat nova_contrail_vif_egg: no such file or directory

Actual results:


Expected results:


Additional info:

Comment 1 Alex Schultz 2019-09-11 20:18:04 UTC
*** Bug 1751340 has been marked as a duplicate of this bug. ***

Comment 2 Alex Schultz 2019-09-11 20:28:52 UTC
I'm unsure we ever supported this. Additionally for OSP15 this may not even work.  If you're mounting in python code, you should be installing the rpms in the container or on the host as this would be the recommended distribution method.

Comment 20 Jad Haj Yahya 2019-10-23 05:59:25 UTC
Verified on 13  -p 2019-10-16.2

Comment 21 Alex McLeod 2019-10-31 11:28:59 UTC
If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field. The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Comment 22 shaju 2019-11-04 16:34:14 UTC
Hi 

Could you please let us know when the fix will be available in CDN ?

Thanks,
Shaju

Comment 24 errata-xmlrpc 2019-11-07 14:02:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3794


Note You need to log in before you can comment on or make changes to this bug.