Bug 1751438 (F31Workstationlivex86_64Oversize) - Workstation x86_64 live image is over size target
Summary: Workstation x86_64 live image is over size target
Keywords:
Status: CLOSED ERRATA
Alias: F31Workstationlivex86_64Oversize
Product: Fedora
Classification: Fedora
Component: LiveCD
Version: 31
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard: AcceptedBlocker
: 1751635 (view as bug list)
Depends On:
Blocks: F31FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-09-12 01:51 UTC by Adam Williamson
Modified: 2019-09-30 15:33 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-30 15:33:46 UTC


Attachments (Terms of Use)

Description Adam Williamson 2019-09-12 01:51:20 UTC
per https://fedoraproject.org/wiki/Releases/31/ReleaseBlocking , the size target for the Workstation live image is 2GB. The image in the Beta-1.1 compose is 2047475712 bytes (just over 2GB).

This is an automatic Beta blocker under the policy: "Any release-blocking Beta or Final TC/RC image exceeding its target size (failures of QA:Testcase_Mediakit_ISO_Size)" - https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers

Comment 1 Adam Williamson 2019-09-12 01:57:00 UTC
Looking at past test results, it went over size between Rawhide 20190621.n.0 and 20190625.n.0. I can't be more specific about sizes for those two composes because the composes themselves have been garbage collected, and compose import to PDC has been broken since March so we don't have the image sizes recorded in PDC :/

Comment 2 Kamil Páral 2019-09-12 09:56:20 UTC
*** Bug 1751635 has been marked as a duplicate of this bug. ***

Comment 3 Adam Williamson 2019-09-12 18:17:26 UTC
so, https://pagure.io/fedora-kickstarts/pull-request/527 is probably what made it go over. podman itself is quite large and it probably pulls in some Go deps that weren't in before.

Comment 4 Adam Williamson 2019-09-12 18:58:14 UTC
Discussed at the Fedora 31 Beta Go/No-Go Meeting #1, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2019-09-12/f31-beta-go_no_go-meeting.2019-09-12-17.00.txt . This clearly violates the release criteria, but we decided to invoke the new "Last minute blocker" policy - https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Exceptional_cases - and waive this to Final as it was proposed as a blocker only yesterday, and is not a particularly critical bug (the 2GB size limit is somewhat arbitrary; the only justifications for it we can think of are 2GB USB sticks, and *possibly* persistence support, though we're not 100% sure on that part).

Comment 5 Kamil Páral 2019-09-13 11:03:47 UTC
Just for reference, here is ticket from the last year in which I inquire Workstation WG whether the Live maximum size should be raised (and they don't want to do that):
https://pagure.io/fedora-workstation/issue/47

Comment 6 Adam Williamson 2019-09-13 15:31:22 UTC
Thanks! Wish I'd had that around during the meeting.

So, per that ticket "If we ever reach that point then we're definitely going to want to sit down and reevaluate what is going into the live image" - time to do some sitting and evaluating, folks :D

Comment 7 Jens Petersen 2019-09-19 07:32:37 UTC
Just noting that we discussed this briefly in the WS WG meeting this week but want to revisit/discuss further in time for GA.

Comment 8 Jens Petersen 2019-09-19 14:34:52 UTC
More details and discussion in https://pagure.io/fedora-workstation/issue/104

Comment 9 Peng Wu 2019-09-24 07:22:01 UTC
I just created one pull request to make google-noto-serif-cjk-ttc-fonts optional for f31 and f32.

URL: https://pagure.io/fedora-comps/pull-request/414

Hope this pull request helps.

Comment 10 Chris Murphy 2019-09-30 15:24:57 UTC
google-noto-serif-cjk-ttc-fonts has been removed and current size should be ~1930952704

Comment 11 Adam Williamson 2019-09-30 15:33:46 UTC
yup, relval size-check passed for Workstation on the most recent compose, so let's call this fixed. (if it goes over again, we now have bug reporting automation in place, so this bug *should* get re-opened automatically).


Note You need to log in before you can comment on or make changes to this bug.