Bug 175150 - pgadmin3 fails dependencies on FC5T1
pgadmin3 fails dependencies on FC5T1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pgadmin3 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gavin Henry
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2005-12-06 18:12 EST by Andy Burns
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.4.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 13:50:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to remove extra (now illegal?) scope qualification from class method names (988 bytes, patch)
2006-01-16 16:55 EST, Andy Burns
no flags Details | Diff
Updated patch (972 bytes, patch)
2006-01-16 17:26 EST, Andy Burns
no flags Details | Diff
Updated spec file to 1.4.1 and patched for gcc4.1 (2.16 KB, text/plain)
2006-01-16 17:31 EST, Andy Burns
no flags Details
New spec file (2.30 KB, text/plain)
2006-01-17 15:22 EST, Andy Burns
no flags Details

  None (edit)
Description Andy Burns 2005-12-06 18:12:13 EST
Description of problem:

postgresql 8.1 installed OK on FC5T1 (well rawhide) and wanted
to install pgadmin III to go along with it.
 
I tried using yum, but it can't solve all dependencies, looks like it
needs rebuilding to pick up different .so names?
 
Version-Release number of selected component (if applicable):

1.0.2-5

How reproducible:

always

Steps to Reproduce:
1. Install FC5T1 or rawhide
2. yum install pgadmin3
3.
  
Actual results:

Error: Missing Dependency: libcrypto.so.5 is needed by package pgadmin3
Error: Missing Dependency: libssl.so.5 is needed by package pgadmin3

Expected results:

pgadmin3 installed

Additional info:

Is it possible that extras might be updated to pgAdmin III v1.4.0
which I believe is best to make use of the new 8.1 features?
Comment 1 Andy Burns 2006-01-16 11:03:15 EST
Remarking open as the v1.4.1 rebuild didn't make it into extras (64bit issues?)

Comment 2 Andy Burns 2006-01-16 16:30:34 EST
I'm having a try at building pgadmin v1.4.1 (rather than 1.4.0) myself on
x86_64, I've grabbed the spec file and .tgz 

I've got lots of warnings from wxWidgets about "dereferencing type-punned
pointer will break strict-aliasing rules" is this new, or have they previously
been ignored?

I also had to remove a redundant (and now outlawed with gcc4.1?) scope
qualification on the destructor for pgSchemaObject

Do you recall what error on what platforms you got from the build system?
Comment 3 Andy Burns 2006-01-16 16:55:29 EST
Created attachment 123268 [details]
Patch to remove extra (now illegal?) scope qualification from class method names

This was required for me to build on FC5T2, I'll submit it upstream too ...
Comment 4 Gavin Henry 2006-01-16 17:03:27 EST
My errors were about old tags and not finding the source.
Comment 5 Andy Burns 2006-01-16 17:26:14 EST
Created attachment 123269 [details]
Updated patch

I couldn't wget the source from the URL in the spec file tonight, so but I
think that  was just because the server was busy ...

Attached is an modified patch, and next I will append my modified .spec file
which applies it, is it possible you can give it a whirl?
Comment 6 Andy Burns 2006-01-16 17:31:27 EST
Created attachment 123270 [details]
Updated spec file to 1.4.1 and patched for gcc4.1
Comment 7 Andy Burns 2006-01-17 15:22:40 EST
Created attachment 123328 [details]
New spec file

I've changed the source location in the package, the original one specified now
seems to require authentication, so wget failed on it, is it possible to let
the build system try it's worst on this now? It builds and works fine for me
now with this .spec file and the previous .patch file

The patch has been committed upstream, but obviously won't appear in the
tarball yet.

Note You need to log in before you can comment on or make changes to this bug.