Bug 1751569 - tpm2-tss 2.1.2 underlinking causing other packages to fail to build
Summary: tpm2-tss 2.1.2 underlinking causing other packages to fail to build
Keywords:
Status: ON_QA
Alias: None
Product: Fedora
Classification: Fedora
Component: tpm2-tss
Version: 29
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Yunying Sun
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-12 07:36 UTC by Richard Hughes
Modified: 2019-09-16 01:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Richard Hughes 2019-09-12 07:36:06 UTC
Description of problem:

fwupd 1.3.1 fails to build with the tpm2-tss-devel package in Fedora 29 with "/usr/bin/ld: cannot find -lgcrypt" when linking.

Version-Release number of selected component (if applicable):

tpm2-tss-2.1.2-1.fc29

How reproducible:

Always

Steps to Reproduce:
1. Install Fedora 29 x64 Workstation
2. Try to build fwupd 1.3.1 with UEFI enabled

Actual results:

Compiling fails with "/usr/bin/ld: cannot find -lgcrypt" when linking the uefi-self-test binary.

Expected results:

Compilation success.

Additional info:

Weirdly, this is x64 specific. Updating to 2.2.3 magically fixes the compile failure on all architectures.

Comment 1 Fedora Update System 2019-09-12 08:46:37 UTC
FEDORA-2019-245d5ca1f1 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-245d5ca1f1

Comment 2 Fedora Update System 2019-09-12 22:39:29 UTC
tpm2-tss-2.2.3-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-245d5ca1f1

Comment 3 Yunying Sun 2019-09-16 01:44:50 UTC
Please note that 2.2.3 update for F29 has been abandonded since there's ABI changes found comparing to F29 last available version 2.1.2: 
https://taskotron.fedoraproject.org/artifacts/all/6e8dc454-d539-11e9-a037-52540077ca13/tests.yml/tpm2-tss-2.2.3-1.fc29.log


Note You need to log in before you can comment on or make changes to this bug.