Bug 1751636 - docker.service fails to start in Fedora rawhide
Summary: docker.service fails to start in Fedora rawhide
Keywords:
Status: CLOSED DUPLICATE of bug 1746355
Alias: None
Product: Fedora
Classification: Fedora
Component: moby-engine
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Olivier Lemasle
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-12 09:54 UTC by Jan Pazdziora
Modified: 2019-09-16 15:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-16 15:23:45 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2019-09-12 09:54:01 UTC
Description of problem:

Starting docker.service (from moby-engine) fails in Fedora rawhide.

Version-Release number of selected component (if applicable):

moby-engine-18.09.8-2.ce.git0dd43dd.fc31.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. dnf install -y docker
2. systemctl start docker

Actual results:

# systemctl start docker
Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xe" for details.

Expected results:

No error, docker should just work.

Additional info:

Running

# systemctl status docker.service --no-pager -l

prints

● docker.service - Docker Application Container Engine
   Loaded: loaded (/usr/lib/systemd/system/docker.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2019-09-12 05:47:41 EDT; 6min ago
     Docs: https://docs.docker.com
  Process: 9713 ExecStart=/usr/bin/dockerd --host=fd:// --exec-opt native.cgroupdriver=systemd $OPTIONS (code=exited, status=1/FAILURE)
 Main PID: 9713 (code=exited, status=1/FAILURE)
      CPU: 184ms

Sep 12 05:47:41 machine.example.test systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
Sep 12 05:47:41 machine.example.test systemd[1]: docker.service: Failed with result 'exit-code'.
Sep 12 05:47:41 machine.example.test systemd[1]: Failed to start Docker Application Container Engine.
Sep 12 05:47:41 machine.example.test systemd[1]: docker.service: Service RestartSec=100ms expired, scheduling restart.
Sep 12 05:47:41 machine.example.test systemd[1]: docker.service: Scheduled restart job, restart counter is at 3.
Sep 12 05:47:41 machine.example.test systemd[1]: Stopped Docker Application Container Engine.
Sep 12 05:47:41 machine.example.test systemd[1]: docker.service: Start request repeated too quickly.
Sep 12 05:47:41 machine.example.test systemd[1]: docker.service: Failed with result 'exit-code'.
Sep 12 05:47:41 machine.example.test systemd[1]: Failed to start Docker Application Container Engine.

Comment 1 Lukas Slebodnik 2019-09-16 15:23:45 UTC

*** This bug has been marked as a duplicate of bug 1746355 ***


Note You need to log in before you can comment on or make changes to this bug.