Bug 1751694 - MATE f31 spin doesn't use f31 background wallpaper
Summary: MATE f31 spin doesn't use f31 background wallpaper
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-desktop
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-09-12 12:10 UTC by Wolfgang Ulbrich
Modified: 2019-09-14 16:34 UTC (History)
2 users (show)

Fixed In Version: mate-desktop-1.22.1-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-14 16:34:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Wolfgang Ulbrich 2019-09-12 12:10:30 UTC
Description of problem:
MATE f31 spin doesn't use f31 background wallpaper

Version-Release number of selected component (if applicable):
1.22.1.2

How reproducible:
Use or install latest mate-compiz spin for f31

Steps to Reproduce:
1.Use or install latest mate-compiz spin for f31

Actual results:

MATE desktop use f30 background

Expected results:

MATE desktop use f30 background

Additional info:

Same procedure than every year.
New background package isn't release before beta freeze.
Spin maintainers aren't informed that a new release is available, eg. in fedora devel mailing list.

I will update Mate gsettings overrides to use new background dir.
[org.mate.background]
picture-filename='/usr/share/backgrounds/f31/default/f31.xml'

Honestly, we need a dir without versions of fedora,
Maybe a symlink /usr/share/backgrounds/default/default.xml to current fedora background release, to avoid this update pain 2 times a year.

Comment 1 Fedora Update System 2019-09-12 12:14:08 UTC
FEDORA-2019-8f3814f787 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8f3814f787

Comment 2 Fedora Blocker Bugs Application 2019-09-12 12:23:13 UTC
Proposed as a Freeze Exception for 31-beta by Fedora user raveit65 using the blocker tracking app because:

 MATE f31 spin doesn't use f31 background wallpaper
I need to update mate-desktop package to use new dir for the f31 default .xml wallpaper with it gsettings overrides.

[org.mate.background]
picture-filename='/usr/share/backgrounds/f31/default/f31.xml'

I don't really get why spin maintainer won't be informed in time when new background package is ready?
Maybe with a short notification in -devel list?
And please before beta freeze.

Comment 3 Wolfgang Ulbrich 2019-09-12 12:31:28 UTC
(In reply to Wolfgang Ulbrich from comment #0)

> Expected results:
> 
> MATE desktop use f30 background
> 

I meant MATE desktop use f31 background of course.

Comment 4 Fedora Update System 2019-09-12 14:45:28 UTC
mate-desktop-1.22.1-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8f3814f787

Comment 5 Fedora Update System 2019-09-14 16:34:35 UTC
mate-desktop-1.22.1-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.