Bug 1751706 - KubeVersionMismatch should be removed [NEEDINFO]
Summary: KubeVersionMismatch should be removed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Lili Cosic
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1791194
TreeView+ depends on / blocked
 
Reported: 2019-09-12 12:35 UTC by Michal Fojtik
Modified: 2020-05-04 11:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: KubeVersionMismatch alert was not useful in OpenShift as during upgrade we can have two Kubernetes versions at once in various components. Consequence: This alert was firing during upgrading between Kubernetes versions. Fix: The KubeVersionMismatch was removed. Result: We should not have that alert firing during Kubernetes version upgrades.
Clone Of:
: 1791194 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:13:32 UTC
Target Upstream Version:
lcosic: needinfo? (mfojtik)
surbania: needinfo? (mfojtik)
lcosic: needinfo? (mfojtik)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 611 0 None closed Bug 1751706: Removing KubeVersionMismatch alert 2020-04-22 09:09:59 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:14:08 UTC

Description Michal Fojtik 2019-09-12 12:35:51 UTC
Description of problem:

The ALERTS{alertname="KubeVersionMismatch",alertstate="firing",severity="warning"} was blocking merging the Openshift API server bump to kubernetes 1.16.0.

This was because the kubernetes apiserver was still running on 1.14.0 for that PR.
Having an alert for this kind of mismatch does not make sense as it is normal that components can run on version skew (typically during upgrade, see: https://bugzilla.redhat.com/show_bug.cgi?id=1684431)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Michal Fojtik 2019-09-12 12:36:58 UTC
Not a 4.2 blocker, but something we should fix in upstream during 4.3

Comment 2 Lili Cosic 2019-10-01 12:44:53 UTC
(In reply to Michal Fojtik from comment #1)
> Not a 4.2 blocker, but something we should fix in upstream during 4.3

How long does an upgrade take? We are thinking of increasing the time for this.

Comment 6 Junqi Zhao 2020-01-16 02:22:31 UTC
Tested with 4.4.0-0.nightly-2020-01-15-181917, KubeVersionMismatch alert is removed
# token=`oc -n openshift-monitoring sa get-token prometheus-k8s`
# oc -n openshift-monitoring exec -c prometheus prometheus-k8s-1  -- curl -k -H "Authorization: Bearer $token" 'https://prometheus-k8s.openshift-monitoring.svc:9091/api/v1/rules' | jq | grep "KubeVersionMismatch"
nothing returned

Comment 8 errata-xmlrpc 2020-05-04 11:13:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.