Bug 175179 - rc.sysinit uses multipath instead of multipath.static
rc.sysinit uses multipath instead of multipath.static
Status: CLOSED DUPLICATE of bug 168321
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 07:49 EST by Thomas Haeberlin
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 11:15:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Haeberlin 2005-12-07 07:49:44 EST
Description of problem:

rc.sysinit uses multipath instead of multipath.static. If the /usr is a 
seperate filesystem, initialization of multipathing devices fails because of 
missing libraries (/usr/lib64/libsysfs.*).

Version-Release number of selected component (if applicable):
initscripts-7.93.20.EL-1

How reproducible:
everytime

Steps to Reproduce:
1.create /usr filesystem
2.create multipath-device configuration
3.reboot

  
Actual results:
multipath-devices are not available after reboot.

Expected results:
multipath-devices available after reboot

Additional info:
should use multipath.static in /etc/rc.sysinit

workaround: 
1. replace multipath with multipath.static in /etc/rc.sysinit
or
2. copy /usr/lib64/libsysfs.* to /lib64 && ldconfig
Comment 1 Bill Nottingham 2005-12-07 11:15:44 EST

*** This bug has been marked as a duplicate of 168321 ***

Note You need to log in before you can comment on or make changes to this bug.