Bug 1751884 - System Fedora 31 freeze when launching graphical interface with a radeon 5700 XT
Summary: System Fedora 31 freeze when launching graphical interface with a radeon 5700 XT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 31
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-12 20:46 UTC by ludo.surfer
Modified: 2019-09-28 00:02 UTC (History)
20 users (show)

Fixed In Version: mesa-19.2.0-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-28 00:02:56 UTC


Attachments (Terms of Use)
dmesg (91.80 KB, text/plain)
2019-09-13 16:49 UTC, ludo.surfer
no flags Details
xorg.log (40.51 KB, text/plain)
2019-09-13 16:49 UTC, ludo.surfer
no flags Details
disabled nomosed xorg log (14.18 KB, text/plain)
2019-09-19 19:45 UTC, dobrevich
no flags Details

Description ludo.surfer 2019-09-12 20:46:14 UTC
Version : last nightlie of Fedora 31

Step to reproduce : Put a Radeon 5700 XT in your rig, and try to run a graphical interface.


Symptoms:

Downloading the last nightlie of Fedora 31, the system boot and when it try to launch the graphical interface, the computer Freezes, a hardware reset is necessary.

What i tried :

Install a basic fedora 31
then do the following:

Sudo dnf update
Sudo dnf install xorg-x11-drv-amdgpu
sudo dnf group install "Bureau Xfce"
Sudo reboot

log in and then type : startx

result : system frozen, a hardware reset is necessary

Comment 1 ludo.surfer 2019-09-12 20:48:24 UTC
Additional comment : My rig works fine with a radeon Vega 56

Comment 2 Michel Dänzer 2019-09-13 07:23:15 UTC
(In reply to ludo.surfer from comment #0)
> Sudo dnf install xorg-x11-drv-amdgpu

It doesn't happen if you leave out this step only?

If so, please attach the Xorg log file and output of dmesg captured after running startx, without installing xorg-x11-drv-amdgpu.

If you can log in from another computer via SSH, you can also try doing so after the freeze and capturing the same information in that case.

Comment 3 ludo.surfer 2019-09-13 16:48:27 UTC
Hello,

Here are the files.

Here are my steps:

Download Fedora 31 beta 1.1
make a basic install
Log in
sudo dnf update
sudo dnf group install 'Bureau Xfce'
sudo reboot
log in
startx
System did not freeze but graphical interface did not launch

Here are the log files asked

Comment 4 ludo.surfer 2019-09-13 16:49:04 UTC
Created attachment 1614924 [details]
dmesg

Comment 5 ludo.surfer 2019-09-13 16:49:31 UTC
Created attachment 1614925 [details]
xorg.log

Comment 6 ludo.surfer 2019-09-14 20:59:58 UTC
I think i have found.

5700 XT need mesa 19.3 and Fedora 31 is with mesa 19.2.....

Comment 7 Michel Dänzer 2019-09-17 16:32:52 UTC
(In reply to ludo.surfer from comment #6)
> 5700 XT need mesa 19.3 and Fedora 31 is with mesa 19.2.....

Mesa 19.2 has Navi 10 support.

The attached log files show "nomodeset" being passed on the kernel command line, which prevents the amdgpu kernel driver from initializing. If the problem happens without nomodeset as well, please attach the corresponding log files.

Comment 8 dobrevich 2019-09-19 19:45:27 UTC
Created attachment 1616895 [details]
disabled nomosed xorg log

Same bug on my system with RX 5700 XT.
After installing mesa-git from https://copr.fedorainfracloud.org/coprs/xxmitsu/mesa-git/ and reboot i can see login. But it takes 10 minutes between fedora boot logo and login screen.

Comment 9 Electron 2019-09-19 20:35:58 UTC
Hello,

I think I have the same problem.

My try:
Write Fedora-Workstation-Live-x86_64-31_Beta-1.1.iso on usb key with disk tool (fedora 30)
(never done before ... I do not have dvd anymore)
Boot with the USB key
text mode (40 columns ?)
switch to (80 columns ?) with many green ok, after a few seconds,
Show "Started GNOME Display Manager."
PC freeze.
Numlock does not work, ALT-F2 no work, need hard reset.

I have a radeon AMD 5700XT, AMD K9 3900x, Asus X570-E GAMING.
Thanks to the developers :-)

Comment 10 ludo.surfer 2019-09-23 21:02:00 UTC
@dobrevich

For me with mesa-git, everything seems ok.
Thank you for the link

Comment 11 Michel Dänzer 2019-09-24 09:36:56 UTC
I think the problem is that Mesa in F31 is compiled against LLVM 8, but Navi 10 is only supported as of LLVM 9.

Comment 12 Steven Haigh 2019-09-24 14:11:44 UTC
Can confirm that enabling the mesa-git copr (https://copr.fedorainfracloud.org/coprs/xxmitsu/mesa-git/) that full functionality is available.

Is it too late in the F31 cycle to punt mesa / llvm to newer versions?

Comment 13 Michel Dänzer 2019-09-25 08:03:52 UTC
(In reply to Steven Haigh from comment #12)
> Is it too late in the F31 cycle to punt mesa / llvm to newer versions?

FWIW, Mesa 19.2 should be fine, only LLVM 9 should be needed.

Comment 14 Fedora Update System 2019-09-26 05:53:40 UTC
FEDORA-2019-52ecb9952b has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-52ecb9952b

Comment 15 Fedora Update System 2019-09-27 02:28:53 UTC
mesa-19.2.0-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-52ecb9952b

Comment 16 Steven Haigh 2019-09-27 15:44:32 UTC
I can confirm that I get to the gnome-shell GUI correctly with the following packages (some still in updates-testing).

$ rpm -qa | grep -E 'mesa|llvm' | sort
llvm-libs-9.0.0-1.fc31.i686
llvm-libs-9.0.0-1.fc31.x86_64
mesa-dri-drivers-19.2.0-1.fc31.i686
mesa-dri-drivers-19.2.0-1.fc31.x86_64
mesa-filesystem-19.2.0-1.fc31.i686
mesa-filesystem-19.2.0-1.fc31.x86_64
mesa-libEGL-19.2.0-1.fc31.x86_64
mesa-libgbm-19.2.0-1.fc31.x86_64
mesa-libGL-19.2.0-1.fc31.i686
mesa-libGL-19.2.0-1.fc31.x86_64
mesa-libglapi-19.2.0-1.fc31.i686
mesa-libglapi-19.2.0-1.fc31.x86_64
mesa-libGLU-9.0.1-1.fc31.x86_64
mesa-libOpenCL-19.2.0-1.fc31.x86_64
mesa-libxatracker-19.2.0-1.fc31.x86_64
mesa-vdpau-drivers-19.2.0-1.fc31.x86_64
mesa-vulkan-drivers-19.2.0-1.fc31.i686
mesa-vulkan-drivers-19.2.0-1.fc31.x86_64

Comment 17 Fedora Update System 2019-09-28 00:02:56 UTC
mesa-19.2.0-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.