Bug 1751905 - OpenShift 4.2 on Azure Installation Failed With Resource Deletion Error
Summary: OpenShift 4.2 on Azure Installation Failed With Resource Deletion Error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.z
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 4.2.0
Assignee: Abhinav Dahiya
QA Contact: Etienne Simard
URL:
Whiteboard:
: 1752112 1756484 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-13 02:26 UTC by Nicholas Chen
Modified: 2020-04-29 06:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:41:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2353 None closed Bug 1751905: data/data/azure/bootstrap: ensure pool is only updated after machine is terminated 2020-08-24 10:10:16 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:41:19 UTC

Description Nicholas Chen 2019-09-13 02:26:24 UTC
Description of problem:

Installing OpenShift 4.2 on azure with following instruation 
https://github.com/openshift/installer
https://try.openshift.com
https://blog.openshift.com/openshift-4-2-on-azure-preview/

Version-Release number of the following components:
$ ./openshift-install version
./openshift-install v4.2.0
built from commit 3f34b38a1a6888bcc64c23f73cee3a7039cb8a70
release image quay.io/openshift-release-dev/ocp-release-nightly@sha256:9b5d0863abafcb98d1be5a4cf153e919530ba79ea4b18c390d602f9284cf916b


How reproducible:

Steps to Reproduce:
1. Install OpenShift according to docs
2. Installation will fail with error during the stage of removing bootstrap.


Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

./openshift-install create cluster
INFO Consuming "Install Config" from target directory 
INFO Creating infrastructure resources...         
INFO Waiting up to 30m0s for the Kubernetes API at https://api.carboncaasaz.zeroharm.com:6443... 
INFO API v1.14.6+13494ae up                       
INFO Waiting up to 30m0s for bootstrapping to complete... 
INFO Destroying the bootstrap resources...  
ERROR                                              
ERROR Error: Error waiting for removal of Backend Address Pool Association for NIC "carboncaasaz-8jspw-bootstrap-nic" (Resource Group "carboncaasaz-8jspw-rg"): Code="OperationNotAllowed" Message="Operation 'startTenantUpdate' is not allowed on VM 'carboncaasaz-8jspw-bootstrap' since the VM is marked for deletion. You can only retry the Delete operation (or wait for an ongoing one to complete)." Details=[] 
ERROR                                              
ERROR                                              
FATAL Terraform destroy: failed to destroy using Terraform
 

Expected results:

Installation finished with no error

Additional info:
Please attach logs from ansible-playbook with the -vvv flag
1. Same error for mac and linux installer

Comment 2 Abhinav Dahiya 2019-09-13 17:36:21 UTC
*** Bug 1752112 has been marked as a duplicate of this bug. ***

Comment 3 Etienne Simard 2019-09-16 20:45:44 UTC
Bug fix verification: positive 

- Verified latest ocp dev preview build (http://mirror.openshift.com/pub/openshift-v4/clients/ocp-dev-preview/latest/) which includes bug fix.

$ ./openshift-install version
./openshift-install v4.2.0
built from commit 2553a84b4f7f704f3eed20cc5ab0ef15572a1f24
release image quay.io/openshift-release-dev/ocp-release-nightly@sha256:1502ff409697a70aa11c1d9024e98f1ee069f8b866cc82c38ebebd5670892d70

$ ./openshift-install create cluster
...
INFO Creating infrastructure resources...         
...
INFO API v1.14.6+bebfa64 up                       
INFO Waiting up to 30m0s for bootstrapping to complete... 
DEBUG Bootstrap status: complete                   
INFO Destroying the bootstrap resources...
...
DEBUG Destroy complete! Resources: 8 destroyed.    
INFO Waiting up to 30m0s for the cluster at https://api...
...
INFO Install complete!
...

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.0-0.nightly-2019-09-16-114316   True        False         39m     Cluster version is 4.2.0-0.nightly-2019-09-16-114316

$ oc get clusteroperator
NAME                                       VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                             4.2.0-0.nightly-2019-09-16-114316   True        False         False      41m
cloud-credential                           4.2.0-0.nightly-2019-09-16-114316   True        False         False      57m
cluster-autoscaler                         4.2.0-0.nightly-2019-09-16-114316   True        False         False      52m
console                                    4.2.0-0.nightly-2019-09-16-114316   True        False         False      43m
dns                                        4.2.0-0.nightly-2019-09-16-114316   True        False         False      57m
image-registry                             4.2.0-0.nightly-2019-09-16-114316   True        False         False      45m
ingress                                    4.2.0-0.nightly-2019-09-16-114316   True        False         False      48m
insights                                   4.2.0-0.nightly-2019-09-16-114316   True        False         False      57m
kube-apiserver                             4.2.0-0.nightly-2019-09-16-114316   True        False         False      55m
kube-controller-manager                    4.2.0-0.nightly-2019-09-16-114316   True        False         False      54m
kube-scheduler                             4.2.0-0.nightly-2019-09-16-114316   True        False         False      53m
machine-api                                4.2.0-0.nightly-2019-09-16-114316   True        False         False      57m
machine-config                             4.2.0-0.nightly-2019-09-16-114316   True        False         False      56m
marketplace                                4.2.0-0.nightly-2019-09-16-114316   True        False         False      52m
monitoring                                 4.2.0-0.nightly-2019-09-16-114316   True        False         False      45m
network                                    4.2.0-0.nightly-2019-09-16-114316   True        False         False      54m
node-tuning                                4.2.0-0.nightly-2019-09-16-114316   True        False         False      53m
openshift-apiserver                        4.2.0-0.nightly-2019-09-16-114316   True        False         False      53m
openshift-controller-manager               4.2.0-0.nightly-2019-09-16-114316   True        False         False      56m
openshift-samples                          4.2.0-0.nightly-2019-09-16-114316   True        False         False      52m
operator-lifecycle-manager                 4.2.0-0.nightly-2019-09-16-114316   True        False         False      56m
operator-lifecycle-manager-catalog         4.2.0-0.nightly-2019-09-16-114316   True        False         False      56m
operator-lifecycle-manager-packageserver   4.2.0-0.nightly-2019-09-16-114316   True        False         False      52m
service-ca                                 4.2.0-0.nightly-2019-09-16-114316   True        False         False      57m
service-catalog-apiserver                  4.2.0-0.nightly-2019-09-16-114316   True        False         False      54m
service-catalog-controller-manager         4.2.0-0.nightly-2019-09-16-114316   True        False         False      54m
storage                                    4.2.0-0.nightly-2019-09-16-114316   True        False         False      53m

Comment 4 Abhinav Dahiya 2019-09-27 18:30:07 UTC
*** Bug 1756484 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2019-10-16 06:41:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922

Comment 6 bhavin192 2020-04-29 06:56:50 UTC
This is the exact commit which solved the issue I believe, leaving it here just in case if anyone is looking for it like I was :) https://github.com/openshift/installer/commit/2ee265b62c51cfe8218395ea9c02bf4125120196


Note You need to log in before you can comment on or make changes to this bug.