Bug 175194 - the application cannot be started - "CrashReporter" not found ..
the application cannot be started - "CrashReporter" not found ..
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Depends On:
  Show dependency treegraph
Reported: 2005-12-07 11:13 EST by mp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-12 06:41:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mp 2005-12-07 11:13:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Just updated to: openoffice.org-core-1:2.0.1-143.2.1@i386 - after #171873 was closed, but this error message appears when trying to run OOo (half way into the splash screen loading process):

The application cannot be started.
Configuration - Descendant Element 'CrashReporter' not found in Node /org.openoffice.Office.Recovery

It appears in an error message window and when run from virtual console it generates no output other than that error message

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start open office
2. wait
3. read error message half way through the splash screen loading process

Actual Results:  error message occurs

Expected Results:  open office should start

Additional info:

openoffice always worked fine on this box, from RH7.3 to FC4 - no problems until #171873 - after which i had to revert to 1.9.x

then that was solved and i updated only to get this error message
Comment 1 Caolan McNamara 2005-12-12 06:19:15 EST
You reverted to 1.9.X from a 2.0.X, that's likely the problem. Can you

> tar czf /tmp/oooprofile.tar.gz ~/.openoffice.org2.0
> rm ~/.openoffice.org2.0/user/registry/cache/org.openoffice.Office.Recovery.dat

and then restart OOo and see if that makes a difference. If it doesn't, then if
you could attach /tmp/oooprofile.tar.gz I'll see if I can reproduce the problem.
Comment 2 mp 2005-12-12 07:56:29 EST
yup! nice one, sorted!! thx

The first execution brought up the splash screen and the blue progress line went
all the way but the writer app did not start, then i ran from cmd line to see
output and it started just fine - then terminated that instance, started a new
from desktop icon "openoffice.org-2.0 -writer".

Running fine - of course it may be that the old random crashing persist - yet to
determine that :)
Comment 3 Pavlos Gerardos 2005-12-13 20:18:06 EST
I'm facing the same problem after the last up2date ran a couple of days ago.
I tried to delete the whole .openoffice.org2.0 folder but that didn"t do much.
Any other ideas?
Comment 4 Caolan McNamara 2005-12-14 03:46:43 EST
Well you could 

rpm --erase `rpm -qf /usr/lib/openoffice.org2.0 | xargs` 

and then see if there is still a /usr/lib/openoffice.org2.0 directory, if so tar
the contents up and attach them here, then rm -rf /usr/lib/openoffice.org2.0 and
re-install the new version.

Did you also revert to an older version and then forward to a newer one ? I've
never seen this problem.

Note You need to log in before you can comment on or make changes to this bug.