Bug 1751951 - When master's IP address does not resolve to its name, ipa-replica-install fails
Summary: When master's IP address does not resolve to its name, ipa-replica-install fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Kaleem
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On: 1364139
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-13 08:10 UTC by Tibor Dudlák
Modified: 2020-03-31 19:56 UTC (History)
7 users (show)

Fixed In Version: ipa-4.6.6-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1364139
Environment:
Last Closed: 2020-03-31 19:55:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
console output of verification steps (18.41 KB, text/plain)
2019-12-18 07:55 UTC, Kaleem
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1083 None None None 2020-03-31 19:56:20 UTC

Comment 6 Tibor Dudlák 2019-09-16 07:47:27 UTC
Fixed upstream
master:
https://pagure.io/freeipa/c/f1e20b45c5deeb25989c87a2d717bda5a31bb084

Comment 7 Tibor Dudlák 2019-09-16 08:07:54 UTC
Sorry missclicked the status it should be POST not MODIFIED.

Comment 10 Kaleem 2019-12-18 07:55:53 UTC
Created attachment 1646035 [details]
console output of verification steps

Comment 11 Jan Pazdziora 2019-12-18 11:59:18 UTC
Kaleem, how did the replica manage to resolve the master's hostname? Was it set in /etc/hosts or was /etc/resolv.conf pointing to master's IP address?

Could you also verify that the old version of replica fails to configure in similar setup, to make sure that the change that went into this bugzilla is actually fixing the issue at hand?

Comment 12 Kaleem 2020-01-13 07:31:34 UTC
(In reply to Jan Pazdziora from comment #11)
> Kaleem, how did the replica manage to resolve the master's hostname? Was it
> set in /etc/hosts or was /etc/resolv.conf pointing to master's IP address?
> 
It was set in /etc/hosts
> Could you also verify that the old version of replica fails to configure in
> similar setup, to make sure that the change that went into this bugzilla is
> actually fixing the issue at hand?
Ok. i will reproduce and update it here.

Comment 14 errata-xmlrpc 2020-03-31 19:55:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1083


Note You need to log in before you can comment on or make changes to this bug.