Bug 175199 - Admin Server won't start on FC4 with SELinux enforcing
Admin Server won't start on FC4 with SELinux enforcing
Status: CLOSED DUPLICATE of bug 174855
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Orla Hegarty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 12:29 EST by Mike Clayton
Modified: 2008-08-11 19:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 13:33:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Clayton 2005-12-07 12:29:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I recently installed FDS 1.0 on a freshly installed and updated FC4 install, everything went fine, untill the end of the setup script when it tried to start the admin server, the error it reported was "no such file or directory". After quite a bit of diging and trial and error, I founf the only way I could get the admin server to start was by setting SELinux to permissive, then it works just fine.

P.S. httpd.worker starts just fine from the command line with SELinux in enforcing mode.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC4 with SELinux enabled and enforcing
2. Install FDS 1.0 rpm for FC4
3. Run FDS setup script
4. ps -A     Note that there are no httpd.worker processes
5. run ./start-admin
6. ps -A     Note that there are no httpd.worker processes
7. Set SELinux to permissive mode
8. run ./start-admin
9. ps -A     Note the admin server (httpd.worker) is now runing

Actual Results:  The admin server wouldn't start untill SELinux was in permissive mode.

Expected Results:  The admin server should have started with SELinux enforcing

Additional info:

This is the error as reported at the end of the setup script:

Can't start Admin server [/opt/fedora-ds/start-admin > /tmp/filertFNGr 2>&1] (error: No such file or directory)
Comment 1 Kevin Unthank 2006-01-30 13:33:52 EST

*** This bug has been marked as a duplicate of 174855 ***
Comment 2 Chandrasekar Kannan 2008-08-11 19:43:09 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.