Bug 1752 - PCMCIA init causes irq starvation on Tecra 8000
PCMCIA init causes irq starvation on Tecra 8000
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
5.2
All Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-24 16:24 EST by andreas.heilwagen
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-01 14:24:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andreas.heilwagen 1999-03-24 16:24:24 EST
Initializing PCMCIA support before all other IRQs have
been referenced, causes interrupt starvation on my
Toshiba Tecra 8000 laptop (my current theory).

The symptom is, that I can boot into single user mode.
If I work with the pcmcia/network/gpm scripts, I get
a completely dead keyboard if I start gpm last.

If gpm is fired up before PCMCIA, everything is ok.
The network scripts are started after PCMCIA now on
my machine.

So please check if you want to reorder the init scripts
and start gpm very early and pcmcia immediately afterwards
before the network stuff.

Here are my current interrupts for completeness...they
shouldn4t be the cause of the interrupt starvation.
  0:     152536          XT-PIC  timer
  1:       9818          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  5:          0          XT-PIC  MS Sound System
  8:          1          XT-PIC  rtc
 10:        660          XT-PIC  3c589_cs
 12:      28242          XT-PIC  PS/2 Mouse
 13:          1          XT-PIC  fpu
 14:       6204          XT-PIC  ide0
 15:          4          XT-PIC  ide1
NMI:          0
ERR:          0
Comment 1 Bill Nottingham 1999-03-25 12:56:59 EST
You should be able to edit /etc/pcmcia/config.opts so
that it excludes certain IRQs. We might take a look
at doing that by default.
Comment 2 David Lawrence 1999-04-01 14:24:59 EST
We unfortunately do not have one of these particular laptops in the
test lab and I am unable to get this to dail on a Toshiba Satellite
that we do have with gpm being loaded after pcmcia services. You will
probably need to tweak your /etc/pcmcia/config.opts file to cause
pcmcia to only use certain interrupts that will work on your
particular laptop. More information on this is available in the
PCMCIA-HOWTO installed with the Red Hat distribution.

Note You need to log in before you can comment on or make changes to this bug.