Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1752027 - Warning message for unhealty Ceph in case of starting Maintenance contains not valid info
Summary: Warning message for unhealty Ceph in case of starting Maintenance contains no...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.2.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: 4.2.0
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-13 13:27 UTC by Artem Hrechanychenko
Modified: 2019-10-16 06:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:41:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (32.46 KB, image/png)
2019-09-13 13:27 UTC, Artem Hrechanychenko
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 2735 0 None closed Bug 1752027: Reword the node maintenance storage health warning 2021-02-02 12:53:14 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:41:23 UTC

Description Artem Hrechanychenko 2019-09-13 13:27:53 UTC
Created attachment 1614888 [details]
screenshot

Description of problem:
When we have degraded Ceph and we trying to run maintenance - we got notification that "Maintenance cannot be started until the health of the storage cluster is restored." but we can do that and we don't have disabled action and we should change that description to something that close to actual things

Version-Release number of selected component (if applicable):
    4.2.0-0.nightly-2019-09-13-040309

How reproducible:
always

Steps to Reproduce:
1.Deploy RHHI with OCS, OCP, CNV
2.Degrade ceph(start maintenance for example)
3.Try to run another maintenance

Actual results:
Ceph warning with "Maintenance cannot be started until the health of the storage cluster is restored"

Expected results:
Ceph warning with "..should not be started"

Additional info:

Comment 2 Udi 2019-09-30 11:04:19 UTC
Verified: 4.2.0-0.nightly-2019-09-27-191818

Comment 3 errata-xmlrpc 2019-10-16 06:41:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.