Bug 1752086 - libqtxdg needs rebuild in EPEL 7
Summary: libqtxdg needs rebuild in EPEL 7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: libqtxdg
Version: epel7
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Zamir SUN
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
Depends On:
Blocks: 1719529 1752094
TreeView+ depends on / blocked
 
Reported: 2019-09-13 16:48 UTC by Raphael Groner
Modified: 2019-10-26 15:21 UTC (History)
8 users (show)

Fixed In Version: libqtxdg-3.3.1-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-26 15:21:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Raphael Groner 2019-09-13 16:48:30 UTC
Description of problem:
Package libfm-qt fails to build from source in EPEL 7.

Version-Release number of selected component (if applicable):
0.11.2-3.el7

Steps to Reproduce:
koji build --scratch epel7 libfm-qt-0.11.2-3.el7.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/libfm-qt

Comment 1 Raphael Groner 2019-09-13 16:49:06 UTC
2019-08-13 02:01:12
Package resolution failed

    Problem: package liblxqt-devel-0.11.1-4.el7.x86_64 requires liblxqt.so.0()(64bit), but none of the providers can be installed
    - package liblxqt-devel-0.11.1-4.el7.x86_64 requires liblxqt(x86-64) = 0.11.1-4.el7, but none of the providers can be installed
    - package liblxqt-0.11.1-4.el7.x86_64 requires libQt5Xdg.so.2()(64bit), but none of the providers can be installed
    - package liblxqt-0.11.1-4.el7.x86_64 requires libQt5XdgIconLoader.so.2()(64bit), but none of the providers can be installed
    - conflicting requests
    - nothing provides qt5-qtbase(x86-64) = 5.9.2 needed by libqtxdg-2.0.0-12.el7.x86_64

Comment 2 Raphael Groner 2019-09-13 16:50:13 UTC
Reassigning. The whole lxqt stack FTBFS.

Comment 3 Fedora Update System 2019-10-01 02:30:26 UTC
FEDORA-EPEL-2019-18ce705d1b has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-18ce705d1b

Comment 4 Fedora Update System 2019-10-04 21:17:50 UTC
libfm-qt-0.14.1-5.el7, liblxqt-0.14.1-5.el7, libqtxdg-3.3.1-5.el7, libsysstat-0.4.2-3.el7, lximage-qt-0.14.1-3.el7, lxqt-about-0.14.1-3.el7, lxqt-admin-0.14.1-3.el7, lxqt-build-tools-0.6.0-3.el7, lxqt-config-0.14.1-3.el7, lxqt-globalkeys-0.14.1-3.el7, lxqt-notificationd-0.14.1-3.el7, lxqt-openssh-askpass-0.14.1-3.el7, lxqt-panel-0.14.1-3.el7, lxqt-policykit-0.14.1-3.el7, lxqt-powermanagement-0.14.1-3.el7, lxqt-qtplugin-0.14.0-7.el7, lxqt-runner-0.14.1-3.el7, lxqt-session-0.14.1-3.el7, lxqt-sudo-0.14.1-3.el7, lxqt-themes-0.14.0-3.el7, menu-cache-1.1.0-1.el7.5, obconf-qt-0.14.1-3.el7, pavucontrol-qt-0.14.1-3.el7, pcmanfm-qt-0.14.1-3.el7, qterminal-0.14.1-3.el7, qtermwidget-0.14.1-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-18ce705d1b

Comment 5 Fedora Update System 2019-10-10 07:27:32 UTC
FEDORA-EPEL-2019-18ce705d1b has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-18ce705d1b

Comment 6 Fedora Update System 2019-10-10 17:31:05 UTC
libfm-qt-0.14.1-5.el7, liblxqt-0.14.1-5.el7, libqtxdg-3.3.1-5.el7, libsysstat-0.4.2-3.el7, lximage-qt-0.14.1-3.el7, lxqt-about-0.14.1-3.el7, lxqt-admin-0.14.1-3.el7, lxqt-build-tools-0.6.0-3.el7, lxqt-config-0.14.1-3.el7, lxqt-globalkeys-0.14.1-3.el7, lxqt-notificationd-0.14.1-3.el7, lxqt-openssh-askpass-0.14.1-3.el7, lxqt-panel-0.14.1-3.el7, lxqt-policykit-0.14.1-3.el7, lxqt-powermanagement-0.14.1-3.el7, lxqt-qtplugin-0.14.0-7.el7, lxqt-runner-0.14.1-3.el7, lxqt-session-0.14.1-3.el7, lxqt-sudo-0.14.1-3.el7, lxqt-themes-0.14.0-3.el7, menu-cache-1.1.0-1.el7.5, obconf-qt-0.14.1-3.el7, openbox-theme-mistral-thin-0-6.20170125.el7, pavucontrol-qt-0.14.1-3.el7, pcmanfm-qt-0.14.1-3.el7, qterminal-0.14.1-3.el7, qtermwidget-0.14.1-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-18ce705d1b

Comment 7 Fedora Update System 2019-10-26 15:21:54 UTC
libfm-qt-0.14.1-5.el7, liblxqt-0.14.1-5.el7, libqtxdg-3.3.1-5.el7, libsysstat-0.4.2-3.el7, lximage-qt-0.14.1-3.el7, lxqt-about-0.14.1-3.el7, lxqt-admin-0.14.1-3.el7, lxqt-build-tools-0.6.0-3.el7, lxqt-config-0.14.1-3.el7, lxqt-globalkeys-0.14.1-3.el7, lxqt-notificationd-0.14.1-3.el7, lxqt-openssh-askpass-0.14.1-3.el7, lxqt-panel-0.14.1-3.el7, lxqt-policykit-0.14.1-3.el7, lxqt-powermanagement-0.14.1-3.el7, lxqt-qtplugin-0.14.0-7.el7, lxqt-runner-0.14.1-3.el7, lxqt-session-0.14.1-3.el7, lxqt-sudo-0.14.1-3.el7, lxqt-themes-0.14.0-3.el7, menu-cache-1.1.0-1.el7.5, obconf-qt-0.14.1-3.el7, openbox-theme-mistral-thin-0-6.20170125.el7, pavucontrol-qt-0.14.1-3.el7, pcmanfm-qt-0.14.1-3.el7, qterminal-0.14.1-3.el7, qtermwidget-0.14.1-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.