Bug 1752117 - shared-mime-info-1.13.1-1.fc30 makes Mint-X icons disappear
Summary: shared-mime-info-1.13.1-1.fc30 makes Mint-X icons disappear
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: shared-mime-info
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-13 17:46 UTC by Jonathan S
Modified: 2019-09-21 17:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 17:27:56 UTC
Type: Bug


Attachments (Terms of Use)
shared-mime-info-1.12-2.fc30 showing Mint-X icons (697.35 KB, image/png)
2019-09-16 13:00 UTC, Jonathan S
no flags Details
shared-mime-info-1.13.1-1.fc30 - Mint-X icons no longer visible (814.87 KB, image/png)
2019-09-16 13:03 UTC, Jonathan S
no flags Details

Description Jonathan S 2019-09-13 17:46:57 UTC
Description of problem:
shared-mime-info-1.13.1-1.fc30 is defective. Applying it made all the Mint-X theme icons disappear - I had Mint-X in use and the icons in use were corrupted.

All the Mint-X icons had disappeared from the menu in the theme settings. Mint-Y icons were there, so I could change to those.

Downgrading to shared-mime-info-1.12-2.fc30 brought back the Mint-X icons.
(For reference, I'm using the Fedora cinnamon spin)

Version-Release number of selected component (if applicable):
shared-mime-info-1.13.1-1.fc30

How reproducible:


Steps to Reproduce:
1.Upgrade to shared-mime-info-1.13.1-1.fc30
2.
3.

Actual results:
Mint-X icons are no longer accessible from the Themes settings. If Mint-X icons are in use, they are no longer applied - icons in use appear corrupted

Expected results:
All installed icons should remain available.

Additional info:
Note that this is shared-mime-info-1.13.1-1.fc30, that is the amended version (and not 1.13-1, which was found defective during testing on bodhi)

Comment 1 Bastien Nocera 2019-09-16 08:53:28 UTC

*** This bug has been marked as a duplicate of bug 1751892 ***

Comment 2 Jonathan S 2019-09-16 12:58:40 UTC
This is *NOT* a duplicate of bug 1751892.

As mentioned above, the bug is in shared-mime-info-1.13.1-1.fc30 - in other words, the amended one. I have never applied shared-mime-info-1.13-1.fc30 (the unamended version).

I attach two screenshots. Note that the installed version of shared-mime-info is shown.

Comment 3 Jonathan S 2019-09-16 13:00:56 UTC
Created attachment 1615536 [details]
shared-mime-info-1.12-2.fc30 showing Mint-X icons

Comment 4 Jonathan S 2019-09-16 13:03:43 UTC
Created attachment 1615537 [details]
shared-mime-info-1.13.1-1.fc30 - Mint-X icons no longer visible

Comment 5 Bastien Nocera 2019-09-16 16:57:21 UTC
Fixed upstream:
https://gitlab.freedesktop.org/xdg/shared-mime-info/merge_requests/43

Comment 6 Jonathan S 2019-09-21 17:27:56 UTC
shared-mime-info-1.14-1.fc30 fixes this problem.

Thanks for solving it.

Closing as solved.


Note You need to log in before you can comment on or make changes to this bug.