Bug 175215 - NFS: inherit-able fsid attribute for configuring exports
NFS: inherit-able fsid attribute for configuring exports
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks: RHEL4NFSFailover
  Show dependency treegraph
 
Reported: 2005-12-07 15:06 EST by Lon Hohberger
Modified: 2009-04-16 16:19 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0173
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 15:25:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Implements fsid inheritance for fs/nfsexport/nfsclient/clusterfs (8.56 KB, patch)
2005-12-07 15:06 EST, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2005-12-07 15:06:11 EST
Description of problem:

Currently, even with device-mapper, there's a good chance that a device will
have a different major/minor number on two different hosts.  This causes
problems with NFS exports because they use the device number to validate file
handles on reboots.

Rgmanager simultates reboots on failover, but unfortauntely, since the device
might change between nodes, all of the filehandles will become invalid (stale).

Fortunately, nfsd provides an export option, "fsid=x", were X is a symbolic file
system ID which should be used instead of the device major/minor numbers in the
file handle.  On a failover, if the fsid matches, the client file handles are
considered good irrespective of whether or not the actual device numbers match.

Making this an inherit-able piece allows users to specify file system IDs as a
property of the mount - rather than the individual client exports.  This is what
most people would want.  Without this, nfsclient resources can not be reused;
the user must create new ones for each service...
Comment 1 Lon Hohberger 2005-12-07 15:06:11 EST
Created attachment 121998 [details]
Implements fsid inheritance for fs/nfsexport/nfsclient/clusterfs
Comment 2 Lon Hohberger 2005-12-07 15:06:49 EST
Patches not in CVS yet.
Comment 3 Lon Hohberger 2005-12-07 15:11:35 EST
Patch in CVS - head, STABLE, RHEL4
Comment 4 Red Hat Bugzilla 2006-01-06 15:25:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0173.html

Note You need to log in before you can comment on or make changes to this bug.