Bug 175218 - [RHEL4] initial setup wizard, setup IMAP, requires restarting evolution to use
[RHEL4] initial setup wizard, setup IMAP, requires restarting evolution to use
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2005-12-07 15:28 EST by Suzanne Hillman
Modified: 2008-02-03 02:31 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-03 02:31:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2005-12-07 15:28:18 EST
Description of problem:
When I set up IMAP via the initial setup wizard, I had to restart evolution in
order to actually be asked for my password and see my mail on the IMAP server.

Doubt it matters, but this is a x86_64, viper box.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Click on mail button in Gnome desktop
2. Go through the wizard, setting up IMAP (I initially told it to detect if it
needed SSL, and then was told to try telling it to use SSL always, before I
tried restarting Evo, if that matters)
3. Try to see mail on the IMAP server
Actual results:
No mail until restart Evo.

Expected results:
Should be able to see one's IMAP mail immediately.

Additional info:
Will check if I can reproduce this by creating a fresh user account (may end up
trying a fresh install, as this is the first time I've tried to use Evo at all
since this was installed).
Comment 1 Dave Malcolm 2005-12-07 15:34:44 EST
Possible dup of 169484? in particular c.f. this:
"I can reproduce the behaviour described in the recipe:  if I switch from "Secure
Password" to Plaintext Password"  and check the "Remember Password" option in
the initial wizard, these settings are not preserved on restart.

However, this bug appears to only affect the initial account creation wizard. 
If I subsequently edit the account, changes made to these fields are preserved
on a restart of Evolution."
Comment 2 Suzanne Hillman 2005-12-07 15:39:30 EST
This is reproducable if I tell it to use SSL 'Whenever possible', rather than
always using it (apparently it doesn't like 'Whenever Possible', and doesn't
cope well with it being changed to what it does like). If I change to Always
SSL, I will need to restart Evo in order for it to work.

I suspect that defaulting to "Always" from the get go will make it happy enough.
Comment 3 Suzanne Hillman 2005-12-07 15:40:20 EST
No, I don't think this is a dup of that other bug, as it appears to relate to
SSL settings, not password settings.
Comment 4 Suzanne Hillman 2005-12-07 15:42:35 EST
I note that if one starts Evo with it set to Always, and moves to 'Whenever
Possible', it copes. It only doesn't cope if it starts with 'Whenever Possible'
and you try to change to 'Always'.

I also note that I'm using my IMAP account on mail.boston.redhat.com
Comment 5 Suzanne Hillman 2005-12-07 15:51:21 EST
Also possibly related: if one's Evo is set up to use POP (in this case, it was
not set up in a way that would work), and then one tries to change to IMAP,
it'll ask for the password but not add the IMAP folders to the mail folders view.

Wasn't sure if it related or not; if you think not, I can make another bug.
Comment 6 Matthew Barnes 2008-02-03 02:31:10 EST
Evolution 2.0.2 is only being updated for security issues.  Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.