Bug 1752249 - Revert skip_if_unavailable default back to true
Summary: Revert skip_if_unavailable default back to true
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F31FinalBlocker, FinalBlocker 1706160 1749868
TreeView+ depends on / blocked
 
Reported: 2019-09-15 08:39 UTC by Miro Hrončok
Modified: 2019-10-07 00:02 UTC (History)
16 users (show)

Fixed In Version: dnf-4.2.9-4.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-07 00:02:01 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2019-09-15 08:39:38 UTC
Based on the FESCo decision, please revert the Fedora change https://fedoraproject.org/wiki/Changes/Set_skip_if_unavailable_default_to_false

See https://pagure.io/fesco/issue/2125#comment-595663 and below.

Comment 1 Jaroslav Mracek 2019-09-16 12:59:25 UTC
I proposed a solution in https://github.com/rpm-software-management/dnf/pull/1484, but this issue is still in the discussion and final approach could significantly differ from the pull-request.

Comment 2 Stephen Gallagher 2019-09-16 15:13:52 UTC
This is a FESCo blocker (I just confirmed this during the FESCo meeting).

Comment 3 Jaroslav Mracek 2019-09-17 18:51:38 UTC
Thanks Steven for information. We are still in discussion with community what would be the best approach and to delivery the final solution because there are multiple requirements from different distributions.

Comment 4 Stephen Gallagher 2019-09-19 11:41:04 UTC
Jaroslav, from my perspective the solution in your PR is sufficient for our needs; upstream can ship a version of the configuration that includes `skip_if_unavailable = False` in the upstream dnf.conf and we can modify that in the Fedora package.

Comment 5 Jaroslav Mracek 2019-09-19 14:02:30 UTC
Update:

We already agreed to ship libdnf defaults (hard-coded defailts in libdnf::Conf) as fallows:
skip_if_unavailable = False
best=false

Now we are discussing how to delivery dnf.conf for particular distributions (still multiple solution available).

Comment 6 Adam Williamson 2019-09-30 16:58:57 UTC
could we please get this sorted ASAP? The longer it gets left lying around the less time we have to check everything is OK with it changed.

Comment 7 Fedora Update System 2019-10-03 15:28:54 UTC
FEDORA-2019-ded8e6872f has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ded8e6872f

Comment 8 Kamil Páral 2019-10-04 11:02:20 UTC
(In reply to Fedora Update System from comment #7)
> FEDORA-2019-ded8e6872f has been submitted as an update to Fedora 31.
> https://bodhi.fedoraproject.org/updates/FEDORA-2019-ded8e6872f

I tested the new default, it seems to be working properly. skip_if_unavailable defaults to True in dnf.conf and the value is really used when the repo has no explicit value set. You can change the default and it affects the repos properly. Common dnf operations seem to work as well, as well as packagekit integration through gnome-software.

Comment 9 Fedora Update System 2019-10-04 22:50:26 UTC
dnf-4.2.9-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ded8e6872f

Comment 10 Fedora Update System 2019-10-07 00:02:01 UTC
dnf-4.2.9-4.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.