Bug 1752272 - Nagios check_disk is returning 'dfree_units 0 0' in output
Summary: Nagios check_disk is returning 'dfree_units 0 0' in output
Keywords:
Status: CLOSED DUPLICATE of bug 1752219
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins
Version: el6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Stephen John Smoogen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-15 14:36 UTC by Brian Daniels
Modified: 2019-09-16 15:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-16 15:12:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Brian Daniels 2019-09-15 14:36:49 UTC
Description of problem:
Before updating to nagios-plugins-disk-2.2.1-17.20190829gitfb792ff.el6.x86_64, the check_disk plugin output looked like:
# /usr/lib64/nagios/plugins/check_disk -w 20% -c 10% -l -e -M -X nfsd

DISK OK| /dev/mapper/vg_fileserver-lv_root=1343MB;1560;1755;0;1951 /dev/vda1=125MB;151;170;0;189 /dev/mapper/luks-d5ca124b-2525-49ed-adff-db1deb93bbb2=5305MB;7206;8107;0;9008

It now has multiple "dfree units" lines before the normal output:
# /usr/lib64/nagios/plugins/check_disk -w 20% -c 10% -l -e -M -X nfsd
dfree_units 0 0
disk_result is 0dfree_units 0 0
disk_result is 0dfree_units 0 0
disk_result is 0dfree_units 0 0
disk_result is 0DISK OK| /dev/mapper/vg_fileserver-lv_root=1345MiB;1560;1755;0;1951 tmpfs=0MiB;296;333;0;371 /dev/vda1=125MiB;151;170;0;189 /dev/mapper/luks-d5ca124b-2525-49ed-adff-db1deb93bbb2=5305MiB;7206;8107;0;9008

This causes the nagios console to only show "dfree_units 0 0" in service status, instead of the disk info.  This is also present on 7 after updating to nagios-plugins-disk-2.2.1-17.20190829gitfb792ff.el7.x86_64 there.  


Version-Release number of selected component (if applicable):
nagios-plugins-disk-2.2.1-17.20190829gitfb792ff.el6.x86_64
nagios-plugins-disk-2.2.1-17.20190829gitfb792ff.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Run /usr/lib64/nagios/plugins/check_disk -w 20% -c 10%

Actual results:
Output has multiple dfree_units lines at start.

Expected results:
Output begins with DISK OK and stats.

Additional info:
Tested on CentOS 6 and 7 with epel.

Comment 1 Stephen John Smoogen 2019-09-16 15:12:17 UTC
I am closing this as a duplicate of 1752219. That one has a patch for this which should fix the issue and I will try to roll out this week.

*** This bug has been marked as a duplicate of bug 1752219 ***


Note You need to log in before you can comment on or make changes to this bug.