Bug 175235 - /etc/sysconfig/logwatch ?
Summary: /etc/sysconfig/logwatch ?
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: logwatch   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-07 22:12 UTC by Reuben Farrelly
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-08 10:18:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Reuben Farrelly 2005-12-07 22:12:36 UTC
At present, config of logwatch is handled through editing
/etc/logwatch/conf/logwatch.conf.

However most FC packages make use of /etc/sysconfig/{$program_name}

To be consistent with this it would make sense if we symlinked
/etc/sysconfig/logwatch to /etc/logwatch/conf/logwatch.conf

I imagine this change would be non intrusive, and for the cost of a symlink we
could have logwatch config in a way which is consistent with other packages.

Comment 1 Ivana Varekova 2005-12-08 10:18:18 UTC
Hello, 
/etc/sysconfig directory is for configuration files of RHEL/FC specific packages
and logwatch does not belong to this group.



Comment 2 Reuben Farrelly 2005-12-08 10:30:56 UTC
Huh?  That doesn't sound right, because if that's the case, how come we have
packages like squid, ntp, iptables, httpd and samba with parts of their config
files in there?

http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/ref-guide/ch-sysconfig.html
states that "The /etc/sysconfig/ directory is where a variety of system
configuration files for Red Hat Enterprise Linux are stored.".

Perhaps a symlink isn't the right thing (there aren't any others which does say
something), but the contents of logwatch.conf certainly seem like the sort of
content that is and has been placed in sysconfig in the past.

It's not for me worth making a big fuss about so I won't be persisting with this
too much.  I would rather other bugs be fixed than spend time debating such
things ;)




Note You need to log in before you can comment on or make changes to this bug.