Bug 1752351 - CSI: Missing FSType when using `oc describe pv`
Summary: CSI: Missing FSType when using `oc describe pv`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: aos-storage-staff@redhat.com
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-16 07:00 UTC by Chao Yang
Modified: 2021-05-07 08:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:13:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kubernetes-kubectl pull 8 0 None closed Bug 1752351: UPSTREAM: 85293: Included FSType in CSI volumes 2020-04-29 08:32:47 UTC
Github openshift oc pull 204 0 'None' closed Bug 1752351: UPSTREAM: 85293: Included FStype in CSI Volumes 2020-04-29 08:32:48 UTC
Github openshift origin pull 24255 0 'None' closed Bug 1752351: UPSTREAM: 85293: Included FSType in CSI volumes 2020-04-29 08:32:47 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:14:26 UTC

Description Chao Yang 2019-09-16 07:00:54 UTC
Description of problem:
Did not get the info FSType when using `oc describe pv`

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-09-15-052022

How reproducible:
Always

Steps to Reproduce:
1. oc describe pv pvc-98ad96dd-d84a-11e9-ad16-06382b3fda86
Name:              pvc-98ad96dd-d84a-11e9-ad16-06382b3fda86
Labels:            <none>
Annotations:       pv.kubernetes.io/provisioned-by: ebs.csi.aws.com
Finalizers:        [kubernetes.io/pv-protection external-attacher/ebs-csi-aws-com]
StorageClass:      foo
Status:            Bound
Claim:             csi/www-test-0
Reclaim Policy:    Delete
Access Modes:      RWO
VolumeMode:        Filesystem
Capacity:          1Gi
Node Affinity:     
  Required Terms:  
    Term 0:        topology.ebs.csi.aws.com/zone in [us-east-2b]
Message:           
Source:
    Type:              CSI (a Container Storage Interface (CSI) volume source)
    Driver:            ebs.csi.aws.com
    VolumeHandle:      vol-05a9029b04088c559
    ReadOnly:          false
    VolumeAttributes:      storage.kubernetes.io/csiProvisionerIdentity=1568603135870-8081-ebs.csi.aws.com
Events:                <none>

Actual results:
Did not get the info FSType when using `oc describe pv`

Expected results:
Should add the FSType when using `oc describe pv`

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 1 Christian Huffman 2019-11-14 16:25:22 UTC
I've submitted a PR [1] upstream to include the FSType when describing CSI volumes.

[1] https://github.com/kubernetes/kubernetes/pull/85293

Comment 3 Christian Huffman 2019-12-03 22:43:04 UTC
The upstream PR [1] has been merged. I've submitted a PR to origin [2] that includes these fixes in OpenShift.

[1] https://github.com/kubernetes/kubernetes/pull/85293
[2] https://github.com/openshift/origin/pull/24255

Comment 4 Christian Huffman 2019-12-16 15:00:42 UTC
This was merged into the openshift/kubernetes-kubectl repo with [1], and will be pulled into openshift/oc as a result. Setting bug to MODIFIED, as this PR is already merged.

[1] https://github.com/openshift/kubernetes-kubectl/pull/8

Comment 7 Chao Yang 2020-02-04 08:27:31 UTC
Passed on 
Server Version: 4.4.0-0.nightly-2020-02-02-201619
Kubernetes Version: v1.17.1

oc describe pv pvc-4c0af8f1-8e5c-41df-bb0b-6169ff16af69
Name:              pvc-4c0af8f1-8e5c-41df-bb0b-6169ff16af69
Labels:            <none>
Annotations:       pv.kubernetes.io/provisioned-by: ebs.csi.aws.com
Finalizers:        [kubernetes.io/pv-protection]
StorageClass:      sc-resize
Status:            Bound
Claim:             kube-system/pvc2
Reclaim Policy:    Delete
Access Modes:      RWO
VolumeMode:        Filesystem
Capacity:          1Gi
Node Affinity:     
  Required Terms:  
    Term 0:        topology.ebs.csi.aws.com/zone in [us-east-2b]
Message:           
Source:
    Type:              CSI (a Container Storage Interface (CSI) volume source)
    Driver:            ebs.csi.aws.com
    FSType:            ext4
    VolumeHandle:      vol-0db4364f6e03a1514
    ReadOnly:          false
    VolumeAttributes:      storage.kubernetes.io/csiProvisionerIdentity=1580800561050-8081-ebs.csi.aws.com
Events:                <none>

Comment 9 errata-xmlrpc 2020-05-04 11:13:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.