Bug 175240 - Installer hangs at random times on x86_64 only
Installer hangs at random times on x86_64 only
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 18:03 EST by Jeff Burke
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-31 11:42:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Console output of boot kernel during installation also lspci and lspci -n (11.98 KB, text/plain)
2005-12-07 18:04 EST, Jeff Burke
no flags Details

  None (edit)
Description Jeff Burke 2005-12-07 18:03:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
   As it stands right now. x86_64 fails it hangs during the full installation.

   I can install x86 RHEL4 U3 on the system.

   It doesn't matter if I do a X based install or a text base install. The
system will hang while either formatting the drive or while installing the
packages. 

   I have also run memtest. It worked.

   I have spoken to John Linville. He believed that a potential fix was added to 
2.6.9-22.25.EL: linux-2.6.9-x8664-32-bit-hang.patch. That did not solve the issue.

   I have tested with the beta kernel 2.6.9-24.EL. The system still hung on a
full install. Before the system hung I was able to goto a differnet terminal and
echo lspci and lspci -n to the console. I will attach a log file to the BZ. 

   I have tried both PXE install and CD installations.

Version-Release number of selected component (if applicable):
kernel-2.6.9-24.EL

How reproducible:
Always

Steps to Reproduce:
1. Try to do a "everything" install on a HT-2000 system.

  

Actual Results:  Ssytem will hang at randomw times during the install. I have seen it hang while formatting, Also during installing packages. No specific package it changes every time I try.

I have also tried changing from using IDE to SATA as a installation drive.

Expected Results:  We should install properly.

Additional info:
Comment 1 Jeff Burke 2005-12-07 18:04:59 EST
Created attachment 122010 [details]
Console output of boot kernel during installation also lspci and lspci -n
Comment 3 John W. Linville 2005-12-09 09:24:34 EST
I have back-ported the latest serverworks driver from upstream in the test 
kernels here: 
 
   http://people.redhat.com/linville/kernels/rhel4/ 
 
If you can get at least a minimal installation, then perhaps you can try 
running these kernels for some time.  Adding-in some disk stress testing would 
probably be good too (presuming it makes it that far). 
Comment 5 Jeff Burke 2006-03-31 11:42:55 EST
After updating the bios the install work as expected. It was not a kernel bug.

Note You need to log in before you can comment on or make changes to this bug.