This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 175242 - Openoffice.org won't connect to ldap; "a driver is not registered for the url"
Openoffice.org won't connect to ldap; "a driver is not registered for the url"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 18:06 EST by Anthony Messina
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-26 04:53:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Initial Error Dialog Screenshot (85.52 KB, image/png)
2005-12-07 18:08 EST, Anthony Messina
no flags Details
More information from the error dialog (78.10 KB, image/png)
2005-12-07 18:09 EST, Anthony Messina
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 135137 None None None Never

  None (edit)
Description Anthony Messina 2005-12-07 18:06:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
after setting up an ldap addressbook, when trying to test the connection or commit changes, openoffice presents you with a dialog box that states "error while connecting to the data source; a driver is not registered for the url; 'sdbc:address:ldap:ldap.anyhost.com:389".

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.1-143.2.1

How reproducible:
Always

Steps to Reproduce:
1. use the addressbook wizard to add an ldap address book
2. try to test the new connection
3. wait for the dialog box
  

Actual Results:  the dialog box appears stating that there is no driver registered for that url.

Expected Results:  the ldap connection should be made.

Additional info:

i marked this "high" because the ldap addresssbook is completely useless without a connection to the ldap server.
Comment 1 Anthony Messina 2005-12-07 18:08:12 EST
Created attachment 122011 [details]
Initial Error Dialog Screenshot
Comment 2 Anthony Messina 2005-12-07 18:09:35 EST
Created attachment 122012 [details]
More information from the error dialog
Comment 3 Caolan McNamara 2005-12-12 06:14:36 EST
Hmm, the default backend is the mozilla addressbook badkend, and the problem is
fundamentally https://bugzilla.mozilla.org/show_bug.cgi?id=135137#c15 We don't
include the driver for that reason.

I think we should include the driver anyway, should be ok for ldap usage.
Comment 4 Anthony Messina 2005-12-14 12:06:54 EST
so until you include the driver (waiting patiently), what are my options to get
ldap addressbooks to work in openoffice?  are their some dependancies that i
might need to resolve that would restore the functionality to openoffice?
Comment 5 Caolan McNamara 2006-01-04 10:20:58 EST
Try recently released 2.0.1.1-4.1, the best solution (not that it's brilliant)
is to setup evolution to use the ldap database, and then use the newly enabled
"evolution ldap" address source and see if that works
Comment 6 Anthony Messina 2006-01-04 18:45:06 EST
unfortunately, while i used to be a regular evolution user, i found that it
became more unreliable with the past year's releases and i mostly only used it
for email anyway.  so i am not using it anymore.  aside from the fact that it
seems like openoffice really shouldn't need to use another program to hack
through to an ldap directory.

are there any plans for implementing a real ldap connection straight from
openoffice to an ldap server? -- i do appreciate your help and suggestions, but
so you know.  my plan is to get rid of microsoft office completely.  the only 2
things i need are true full ldap addressbook functionality and better envelope
printing.
Comment 7 Caolan McNamara 2006-01-26 04:53:42 EST
The only available workable option for 2.0.1/2 for ldap addressbooks is the evo
ldap bridge :-(. That's the best we can offer right now.

Note You need to log in before you can comment on or make changes to this bug.