Bug 175243 - libXt-devel appears to be missing a dependency
libXt-devel appears to be missing a dependency
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libXt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 18:08 EST by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 18:18:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2005-12-07 18:08:01 EST
Trying to build mozilla from source I get this:

In file included from gtk2xtbin.c:61:
/usr/include/X11/Shell.h:54:26: error: X11/SM/SMlib.h: No such file or directory

rpm -qf /usr/include/X11/Shell.h
libXt-devel-0.99.2-3

X11/Shell.h contains this line:
#include <X11/SM/SMlib.h>

ls /usr/include/X11/SM
ls: /usr/include/X11/SM: No such file or directory

So it looks like libXt-devel needs another devel package installed for this to
work, which suggests to be that libXt-devel should depend on that devel package.

(which package, if any, should I be installing?)
Comment 1 Dave Malcolm 2005-12-07 18:14:09 EST
Sorry... I now suspect the problem may be at my end
libSM-devel was installed, and seems to be providing /usr/include/X11/SM/SMlib.h

Am investigating...
Comment 2 Dave Malcolm 2005-12-07 18:18:48 EST
Yes, problem is at my end:  "rpm -q -requires libXt-devel" gives:
libSM-devel
libX11-devel
libXt = 0.99.2-3
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

and libSM-devel provides the required file.

Sorry for the noise.
Comment 3 Dave Malcolm 2005-12-07 18:40:19 EST
Something's gone wrong here, dunno if it's at my end or yours:

rpm -V libSM-devel
........C   /usr/include/X11
missing     /usr/include/X11/SM
missing     /usr/include/X11/SM/SM.h
missing     /usr/include/X11/SM/SMlib.h
missing     /usr/include/X11/SM/SMproto.h
........C   /usr/lib/libSM.so
........C   /usr/lib/pkgconfig
........C   /usr/lib/pkgconfig/sm.pc
Comment 4 Dave Malcolm 2005-12-07 18:44:49 EST
reinstalling the package seems to have fixed it, so I suspect some kind of snafu
at my end; keeping as CLOSED NOTABUG.
Comment 5 Mike A. Harris 2005-12-08 03:03:02 EST
The problem is a monolithic X to modular X upgrade problem which goes away
if you reinstall the package.  It's due to /usr/include/X11 being a symlink
in monolithic X, and the modular rpm installing through the symlink into
/usr/X11R6/lib/X11/include, then the symlink being removed.  The files vanish
from rpm context, but are "lost" to package management under the X11R6
hierarchy.

That is only a temporary problem tho which will be resolved somewhat in test2,
once I have a dependency on xorg-x11-filesystem added to all library -devel
packages.  Systems which upgraded from FC4 or earlier to test1, or to rawhide
prior to the fixes will have the "lost" files described above, and require
manual upgrading.  Once everything is fixed for test2 though, FC4 and
earlier systems will upgrade correctly in theory as far as the FC included
packages are concerned, however non-X packages that have abused the filesystem
and installed their wares into X owned include dir, will lose bigtime. ;)

So, this problem is X packaging related and due to rpm limitations, but we've
got a workaround in the works that got delayed due to RHEL3/4 update cycle
which should hit rawhide in a few days.

HTH

Note You need to log in before you can comment on or make changes to this bug.