Bug 175253 - libGLU-devel should require libGL-devel
Summary: libGLU-devel should require libGL-devel
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-08 05:41 UTC by Ralf Corsepius
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: mesa-6.4.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 09:35:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2005-12-08 05:41:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
libGLU-devel should "Require: libGL-devel".

Because:
1) GL/glx.h: #include <GL/gl.h>
2) libGLU.so is linked against libGL.so.*


Version-Release number of selected component (if applicable):
mesa-libGLU-devel-6.4-5

How reproducible:
Always

Steps to Reproduce:
1. Try building a libGLU based application's rpm which 
BuildRequires: libGLU-devel
only.


Actual Results:  Building will fail, because libGL-devel is not being pulled in.


Expected Results:  "BuildRequire: libGLU-devel" should pull-in all required packages, libGLU-devel depends on.


Additional info:

Comment 1 Mike A. Harris 2005-12-21 09:35:47 UTC
Thanks for the report.  Fixed in mesa-6.4.1-2


Note You need to log in before you can comment on or make changes to this bug.