Bug 1752532 - upgrade from 3.11 failed to upgrade es settings from configmap
Summary: upgrade from 3.11 failed to upgrade es settings from configmap
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.11.z
Assignee: Rich Megginson
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-16 15:01 UTC by Rajnikant
Modified: 2019-10-18 01:34 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-18 01:34:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible logging upgrade elasticsearch config diffs (4.06 KB, patch)
2019-09-17 19:49 UTC, Rich Megginson
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-ansible pull 11917 None closed Bug 1752532: upgrade from 3.11 failed to upgrade es settings from configmap 2020-07-10 16:15:33 UTC
Red Hat Product Errata RHBA-2019:3139 None None None 2019-10-18 01:34:50 UTC

Description Rajnikant 2019-09-16 15:01:28 UTC
Description of problem:
elasticsearch container failed to start in logging cluster

Version-Release number of selected component (if applicable):
v3.11.117

How reproducible:
- While upgrading logging cluster to 3.11.117, failed while checking es pod to ready.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 36 Rich Megginson 2019-09-17 19:49:41 UTC
Created attachment 1615994 [details]
ansible logging upgrade elasticsearch config diffs

Comment 43 Anping Li 2019-10-12 07:33:14 UTC
The old elasticsearch configmap are saved as logging-elasticsearch.old

$ oc get configmap
NAME                        DATA   AGE
logging-elasticsearch       2      1h
logging-elasticsearch.old   2      9m

Comment 45 errata-xmlrpc 2019-10-18 01:34:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3139


Note You need to log in before you can comment on or make changes to this bug.