Bug 175255 - dmix is busted for alsa-lib-1.0.10-2.FC4
dmix is busted for alsa-lib-1.0.10-2.FC4
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
Depends On:
  Show dependency treegraph
Reported: 2005-12-08 03:02 EST by Hesty
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-13 10:57:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
asoundrc file (3.89 KB, text/plain)
2005-12-09 21:12 EST, Hesty
no flags Details
dmix.conf (1.10 KB, text/plain)
2005-12-12 08:02 EST, Clive Messer
no flags Details
dsnoop.conf (1.09 KB, text/plain)
2005-12-12 08:02 EST, Clive Messer
no flags Details
alsa.conf (7.29 KB, text/plain)
2005-12-12 08:03 EST, Clive Messer
no flags Details
ainit.conf (421 bytes, text/plain)
2005-12-12 08:04 EST, Clive Messer
no flags Details

  None (edit)
Description Hesty 2005-12-08 03:02:15 EST
Description of problem:
dmix doesn't work with the latest alsa-lib-1.0.10-2.FC4

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install/Upgrade to alsa-lib-1.0.10-2.FC4.
2. Use .asoundrc that uses dmix.
3. Run any audio player.
Actual results:
For example, mplayer complains:
alsa-init: 1 soundcard found, using: default
ALSA lib pcm_direct.c:815:(snd_pcm_direct_initialize_slave) requested or
auto-format is not available
ALSA lib pcm_dmix.c:844:(snd_pcm_dmix_open) unable to initialize slave
alsa-init: playback open error: Invalid argument
Could not open/initialize audio device -> no sound.

Expected results:
dmix should work.

Additional info:
If I remove .asoundrc, sound works again, albeit without any mixing.
Comment 1 Hesty 2005-12-08 03:06:55 EST
Additional info:
Soundcard: Chaintech AV710
Driver: snd_ice1724
I'm also using the fancy "Wolfson DAC" output (rear surround) from this card,
instead of the usual line-out.
Comment 2 Martin Stransky 2005-12-08 04:08:43 EST
Please re-login...
Comment 3 Hesty 2005-12-08 13:50:34 EST
Re-login? I've tried rebooting and it still doesn't help.
Comment 4 Lonni J Friedman 2005-12-08 18:44:55 EST
Same problem here since the update in both xmms and mplayer when either uses
alsa for audio.  Switching either over to oss and life is good again.

I'm using snd_intel8x0 for sound on an 'nVidia Corporation nForce2 AC97 Audio
Comment 5 Lonni J Friedman 2005-12-08 18:47:10 EST
also, i'm using 2.6.14-1.1644_FC4 (x86) with XFCE as my window manager.

Someone else I know is also hitting this problem with KDE, but i don't have
specifics on his hardware or configuration, other than alsa audio stopped
working after the update today.
Comment 6 Martin Stransky 2005-12-09 05:31:20 EST
Do you have /etc/alsa/pcm/dmix.conf and /etc/alsa/pcm/dsnoop.conf files?
Could you attach your .asoundrc file?
Comment 7 Tim Wunder 2005-12-09 08:38:10 EST
I have a similar problem, although I do not think dmix is involved. I do not  
have a ~/.asoundrc file. I use kde from kde-redhat, currently kde-3.5.0, and 
cannot use ALSA anymore as the sound server since upgrading ALSA. Prior to the 
update sound worked fine. I can, however, use OSS.  
$ ll /etc/alsa/pcm/dmix.conf /etc/alsa/pcm/dsnoop.conf  
-rw-r--r--  1 root root 1111 Dec  9 08:19 /etc/alsa/pcm/dmix.conf  
-rw-r--r--  1 root root 1117 Dec  9 08:19 /etc/alsa/pcm/dsnoop.conf  
$ cat ~/.asoundrc  
cat: /home/dad/.asoundrc: No such file or directory  
$ locate asoundrc  
$ rpm -qa|grep alsa  
I use a soundblaster emu10k1 sound card/driver.  
Based on a recommendation of a fellow kde-redhat user, I did:  
ln -s /etc/alsa/ainit.conf /usr/share/alsa/  
ln -s /etc/alsa/alsa.conf /usr/share/alsa/  
and ainit $MY_USER start  
But after that, ALSA still fails. Prior to that, however, kmix and amarok 
would crash, even when using OSS. Afterwards, kmix and amarok ran fine under 
BTW, I'm the KDE user referenced in comment #5... 
Comment 8 Lonni J Friedman 2005-12-09 10:17:45 EST
Interestingly, my problems seem to have gone away since logging out and logging
back in.  Even so, seems bad that alsa would get broken in this fashion just
from an update.
Comment 9 Hesty 2005-12-09 21:12:31 EST
Created attachment 122092 [details]
asoundrc file

I have dmix.conf, dmix.conf.lock, dmix.conf.template, dsnoop.conf,
dsnoop.conf.lock, dsnoop.conf.template under /etc/alsa/pcm/. My .asoundrc is
Comment 10 Clive Messer 2005-12-12 08:00:27 EST
I have the same issue. ie. sound system stops working after update to    
alsa-lib-1.0.10-2.FC4 with dmixed snd_intel8x0 device. After reboot will work 
for a random period of time, but sound will always stop working sooner or 
later. Have reverted to alsa-lib-1.0.9rf-2.FC4 and left amarok playing for 24 
hours and do not have the issue.  
Comment 11 Clive Messer 2005-12-12 08:02:03 EST
Created attachment 122129 [details]
Comment 12 Clive Messer 2005-12-12 08:02:43 EST
Created attachment 122130 [details]
Comment 13 Clive Messer 2005-12-12 08:03:27 EST
Created attachment 122131 [details]
Comment 14 Clive Messer 2005-12-12 08:04:01 EST
Created attachment 122132 [details]
Comment 15 Martin Stransky 2005-12-12 08:19:23 EST
I guess it's caused by difference between alsa-lib and drivers in kernel (here
is 1.0.10rc).
Comment 16 Martin Stransky 2005-12-22 11:12:10 EST
Could you please check this alsa-lib package?


You have to recompile it, REMOVE the old one (which comes with FC4 update) and
install it.
Comment 17 Lonni J Friedman 2005-12-22 11:24:21 EST
What is different/changed in this new package?  
Comment 18 Tim Wunder 2005-12-22 14:31:46 EST
alsamixer fails to run for me with either 1.0.10 alsa-libs installed. 
$ alsamixer  
ALSA lib control.c:739:(snd_ctl_open_noupdate) Invalid CTL default  
alsamixer: function snd_ctl_open failed for default: No such file or directory  
$ rpm -qa|grep alsa 
Comment 19 Clive Messer 2005-12-23 03:54:34 EST
[clivem@fedora:/etc/alsa]$ rpm -q alsa-lib 
[clivem@fedora:/etc/alsa]$ aplay 
ALSA lib pcm_dmix.c:1101:(_snd_pcm_dmix_open) The field ipc_gid must be a 
valid group (create group audio) 
aplay: main:544: audio open error: Invalid argument 
This is because dmix.conf has 'ipc_gid audio' and audio group does not exist 
on my system? 
Comment 20 Martin Stransky 2005-12-23 08:10:17 EST
(In reply to comment #19)
> This is because dmix.conf has 'ipc_gid audio' and audio group does not exist 
> on my system? 

Yes. Please remove this line from /etc/alsa/pcm/dmix.conf and
/etc/alsa/pcm/dsnoop.conf files.

This new test package doesn't have any RH patches, it's only clear upstream
package for driver which is included in the current FC4 kernel.
Comment 21 Martin Stransky 2006-01-03 10:32:39 EST
Some how-to for the latest alsa-driver and FC4 is here:
Comment 22 Hesty 2006-01-04 02:29:09 EST
Fix from comment #16 works for me. I didn't try the one from comment #21. Is
there anything new from alsa-lib-1.0.10-2 compared to alsa-lib-1.0.10-1? Thanks,
Comment 23 Tim Wunder 2006-01-04 07:02:03 EST
Neither the fix from comment #16 nor the one from comment #21 worked for me.
alsamixer segfaults on me.
$ aplay
ALSA lib conf.c:2827:(snd_config_hook_load) cannot access file
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM default definition
(id: default, value: cards.pcm.default)
aplay: main:544: audio open error: Invalid argument

This could be a configuration issue on my system. I'll need to do some more
checking on that and get back to you...
I do not have a /usr/share/alsa/cards directory.
$ ls -al /usr/share/alsa/
total 24
drwxr-xr-x    3 root root  4096 Dec 23 17:17 .
drwxr-xr-x  278 root root 12288 Dec 18 20:10 ..
lrwxrwxrwx    1 root root    20 Dec 23 17:17 ainit.conf -> /etc/alsa/ainit.conf
lrwxrwxrwx    1 root root    19 Dec 23 17:17 alsa.conf -> /etc/alsa/alsa.conf
drwxr-xr-x    2 root root  4096 Jan  3 11:35 speaker-test

What is the minimal configuration for alsa? What configuration files may affect
Comment 24 Martin Stransky 2006-01-04 07:58:20 EST
Do you have the /etc/alsa/cards directory? Because /usr/share/alsa is symlink to
/etc/alsa. You need to have the cards directory here (in /etc/alsa).
Comment 25 Tim Wunder 2006-01-04 08:27:23 EST
I have the /etc/alsa/cards directory. My /usr/share/alsa directory does not
appear to be a symlink
$ ls -al /usr/share|grep alsa
drwxr-xr-x    3 root root    4096 Dec 23 17:17 alsa

I made it a symlink: 
$ ls -al /usr/share|grep alsa
lrwxrwxrwx    1 root root       9 Jan  4 08:21 alsa -> /etc/alsa
but cannot test sound since I'm currently remote to the machine affected. Unless
alsamixer and aplay can be run remotely...

$ alsamixer

alsamixer: function snd_ctl_open failed for default: Permission denied

$ aplay
ALSA lib conf.c:1578:(snd_config_load1) _toplevel_:51:23:No such file or directory
ALSA lib conf.c:2823:(snd_config_hook_load) /usr/share/alsa/cards/aliases.conf
may be old or corrupted: consider to remove or fix it
ALSA lib conf.c:2686:(snd_config_hooks_call) function snd_config_hook_load
returned error: No such file or directory
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM default definition
(id: default, value: cards.pcm.default)
aplay: main:544: audio open error: Invalid argument
Comment 26 Martin Stransky 2006-01-04 08:36:48 EST
You have to check it locally because you need the console lock (you'll get it
after login to console as a common user).
Comment 27 Tim Wunder 2006-01-04 23:09:31 EST
OK, tested it. ALSA now works. Well, it produces sound. alsamixer segfaults when
run from the command line. After the segfault, the console behaves wierdly, as
if some control characters were sent and the screwed things up, and needs to be

If I run alsamixer from a virtual terminal (Ctrl-Alt-F1), the following (or a
portion thereof -- it's not consistent) occasionally will get displayed at the
top of the screen:
"alsamixer: relocation error: alsamixer: symbol snd_mixer_selem_get_playback_dB,
version ALSA_0.9 not defined in file libasound.so.2 with link time reference
Kernel 2.6.14-1.1653_FC4 on an i686"

$ locate libasound.so.2

$ rpm -qf /lib/libasound.so.2
$ rpm -qf /usr/lib/libasound.so.2

After removing libasound2-1.0.9rf-21.rhfc2.at, alsamixer works :)

Must be a remnant of my upgrade from FC2. When alsa 1.0.9 was installed by the
upgrade, it didn't matter that the ATrpms version for FC2 was still around. But
after the update to 1.0.10, that did matter. It's a wonder alsa *ever* worked on
my system (it did, honestly...). Didn't hlep the troubleshooting process to have
the ATrpms' alsa be called libasound2 while FC4's is alsa-lib...

Comment 28 Martin Stransky 2006-01-13 10:57:16 EST
Should be fixed in RAWHIDE (FC5).
Comment 29 André Fettouhi 2006-01-23 07:01:07 EST
Since it is fixed in FC5, will the fix be available for FC4?

Kind Regards

André Fettouhi
Comment 30 Martin Stransky 2006-01-23 10:09:41 EST
It should be fixed in alsa-lib-1.0.10-3.FC4, too.

Note You need to log in before you can comment on or make changes to this bug.