Bug 1752550 - soas live beta unable to login to liveuser
Summary: soas live beta unable to login to liveuser
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gwebsockets
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F31FinalFreezeException, FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-09-16 15:30 UTC by satellitgo
Modified: 2019-09-27 01:28 UTC (History)
9 users (show)

Fixed In Version: gwebsockets-0.6-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-27 01:28:42 UTC


Attachments (Terms of Use)

Description satellitgo 2019-09-16 15:30:57 UTC
Description of problem:
soas live unable to login to liveuser

Version-Release number of selected component (if applicable):
f31 beta

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Blocker Bugs Application 2019-09-16 15:44:30 UTC
Proposed as a Freeze Exception for 31-beta by Fedora user satellit using the blocker tracking app because:

 no blocking DE

Comment 2 Alex Perez 2019-09-17 22:35:04 UTC
on F31 beta, sugar DE fails to start with “ImportError: No module named http.client”

This appears to be because the 0.5 version of gwebsockets is python3-only, but Sugar 0.114 is still python 2.

Comment 3 James Cameron 2019-09-17 23:11:56 UTC
https://github.com/sugarlabs/gwebsockets/commit/291c516919d0b239e70b5bf84be03a6a79601589.patch adds support for both python 2 and python 3 to gwebsockets.  tested with "for x in 2 3; do python$x -c 'import gwebsockets'; done"

Comment 4 Fedora Update System 2019-09-18 00:44:34 UTC
FEDORA-2019-9d82cf770e has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9d82cf770e

Comment 5 Alex Perez 2019-09-18 18:19:24 UTC
Gwebsockets has been released, with proper support for both Python 3 and 2, configurable at compile time. This is required to fix the problem with Sugar 0.114 not starting in the F31 betas.

https://github.com/sugarlabs/gwebsockets/archive/v0.6.tar.gz

Comment 6 Fedora Update System 2019-09-19 02:29:44 UTC
gwebsockets-0.6-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9d82cf770e

Comment 7 Geoffrey Marr 2019-09-23 18:18:43 UTC
Discussed during the 2019-09-23 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" was made as it fixes a non-release-blocking desktop with a live image; this can't be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-23/f31-blocker-review.2019-09-23-16.03.txt

Comment 8 Fedora Update System 2019-09-27 01:28:42 UTC
gwebsockets-0.6-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.