Bug 1752785 - [abrt] assertion failed: (priv->handshake_context) in verify_certificate_cb() at ../tls/gnutls/gtlsconnection-gnutls.c:1949
Summary: [abrt] assertion failed: (priv->handshake_context) in verify_certificate_cb()...
Keywords:
Status: CLOSED DUPLICATE of bug 1719987
Alias: None
Product: Fedora
Classification: Fedora
Component: glib-networking
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:b5decf02f64b50a30e0bb140e1c...
: 1754258 1779914 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-17 08:35 UTC by Andre Klapper
Modified: 2019-12-05 11:17 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-23 15:47:13 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (102.48 KB, text/plain)
2019-09-17 08:35 UTC, Andre Klapper
no flags Details
File: cgroup (231 bytes, text/plain)
2019-09-17 08:35 UTC, Andre Klapper
no flags Details
File: core_backtrace (46.45 KB, text/plain)
2019-09-17 08:35 UTC, Andre Klapper
no flags Details
File: dso_list (20.57 KB, text/plain)
2019-09-17 08:35 UTC, Andre Klapper
no flags Details
File: limits (1.29 KB, text/plain)
2019-09-17 08:35 UTC, Andre Klapper
no flags Details
File: maps (126.71 KB, text/plain)
2019-09-17 08:36 UTC, Andre Klapper
no flags Details
File: open_fds (1.53 KB, text/plain)
2019-09-17 08:36 UTC, Andre Klapper
no flags Details
File: proc_pid_status (1.33 KB, text/plain)
2019-09-17 08:36 UTC, Andre Klapper
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/glib-networking/issues/97 0 None None None 2019-09-23 07:49:22 UTC

Description Andre Klapper 2019-09-17 08:35:47 UTC
Description of problem:
Flaky wifi at conf.

Version-Release number of selected component:
evolution-data-server-3.32.4-1.fc30

Additional info:
reporter:       libreport-2.10.1
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-source-registry
crash_function: verify_certificate_cb
executable:     /usr/libexec/evolution-source-registry
journald_cursor: s=b822d92cd4074967a4d9ece75988e24f;i=1abedf;b=8cb83388232d411d9eaf649366a21069;m=17e6921db;t=592ac7da068aa;x=94de123a18759463
kernel:         5.2.14-200.fc30.x86_64
mountinfo:      
rootdir:        /
type:           CCpp

Comment 1 Andre Klapper 2019-09-17 08:35:52 UTC
Created attachment 1615772 [details]
File: backtrace

Comment 2 Andre Klapper 2019-09-17 08:35:53 UTC
Created attachment 1615773 [details]
File: cgroup

Comment 3 Andre Klapper 2019-09-17 08:35:56 UTC
Created attachment 1615774 [details]
File: core_backtrace

Comment 4 Andre Klapper 2019-09-17 08:35:58 UTC
Created attachment 1615775 [details]
File: dso_list

Comment 5 Andre Klapper 2019-09-17 08:35:59 UTC
Created attachment 1615776 [details]
File: limits

Comment 6 Andre Klapper 2019-09-17 08:36:03 UTC
Created attachment 1615777 [details]
File: maps

Comment 7 Andre Klapper 2019-09-17 08:36:04 UTC
Created attachment 1615778 [details]
File: open_fds

Comment 8 Andre Klapper 2019-09-17 08:36:06 UTC
Created attachment 1615779 [details]
File: proc_pid_status

Comment 9 Milan Crha 2019-09-17 10:02:20 UTC
Thanks for a bug report. I see in the backtrace two threads managed by glib-networking hitting the same assertion:

> assertion failed: (priv->handshake_context)

from verify_certificate_cb() at ../tls/gnutls/gtlsconnection-gnutls.c:1949, each for a different session. as these threads are fully managed by glib-networking, I'm moving the bug there for further investigation.

Comment 10 Milan Crha 2019-09-23 07:44:47 UTC
*** Bug 1754258 has been marked as a duplicate of this bug. ***

Comment 11 Michael Catanzaro 2019-09-23 15:47:13 UTC

*** This bug has been marked as a duplicate of bug 1719987 ***

Comment 12 Milan Crha 2019-12-05 11:16:00 UTC
*** Bug 1779914 has been marked as a duplicate of this bug. ***

Comment 13 Milan Crha 2019-12-05 11:17:19 UTC
The last duplicate is from Fedora 31.


Note You need to log in before you can comment on or make changes to this bug.