This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 175283 - FTP to NFS Client hangs if NFS server is down
FTP to NFS Client hangs if NFS server is down
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: wu-ftpd (Show other bugs)
2.1
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Maros Barabas
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-08 10:12 EST by shan
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:20:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Sysreport (134.21 KB, text/plain)
2005-12-08 10:20 EST, shan
no flags Details

  None (edit)
Description shan 2005-12-08 10:12:04 EST
Description of problem:
FTP to NFS Client ( RHEL 2.1 -- ia64 --WU-ftpd ) hangs if NFS server is down.
Telnet happens Fine in this situation , also here there is no need for the 
exported file system available   for FTP to function fine.

In case of  Vsftpd (RHEL -4)  ftp to the NFS client ( RHEL 4 --VSFTPD)functions 
fine  even when the NFS server is down.



Version-Release number of selected component (if applicable):	wu-ftpd-2.6.1-20


How reproducible:

Case 1. 
Mounted the /tmp folder of the NFS server (RHEL 4) to a NFS Client (RHEL 2.1). 
Shutdown the NFS server (RHEL 4) , FTP to NFS Client( RHEL 2.1) failed , with 
Session time Out message. 
Note :-In the tested Lab system , RHEL 2.1 is with the latest versions of nfs-
utils , portmap , wu-ftpd for RHEL 2.1. 
Case 2. 
Mounted the /tmp folder of the NFS server (RHEL 2.1) to a NFS Client (RHEL 4). 
Shutdown the NFS server (RHEL 2.1) , FTP to NFS Client( RHEL 4) is happening 
fine . 


  
Actual results:When the NFS server is down FTP to WU-FTPD will fail where as 
FTP  to VSFTPD will work fine.


Expected results:FTP to WU-ftpd should work similar to VSftpd , even when the 
NFS server is down as there is no relation between the exported file system 
(/tmp) and the ftp login.


Additional info: RHEL 2.1 (wu-ftpd) packages is installed and tested with the 
latest updates version available in the rhn.redhat.com 

Hence a wu-ftpd version or any other FTP package is needed for RHEL 2.1 in 
which the ftp won’t get affected due to the NFS server in-availability.
Comment 1 shan 2005-12-08 10:20:00 EST
Created attachment 122032 [details]
Sysreport
Comment 2 RHEL Product and Program Management 2007-10-19 15:20:07 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.