Bug 1752849 - Incorrect message is displayed when ipa-healthcheck tool is run with --output-type=human
Summary: Incorrect message is displayed when ipa-healthcheck tool is run with --output...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: ipa-healthcheck
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Rob Crittenden
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-17 12:06 UTC by Sudhir Menon
Modified: 2020-04-28 15:43 UTC (History)
5 users (show)

Fixed In Version: ipa-healthcheck-0.4-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 15:43:29 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1640 0 None None None 2020-04-28 15:43:59 UTC

Description Sudhir Menon 2019-09-17 12:06:13 UTC
Description of problem: Incorrect message is displayed when ipa-healthcheck tool is run with --output-type=human


Version-Release number of selected component (if applicable):
ipa-server-4.8.0-10.module+el8.1.0+4098+f286395e.x86_64
ipa-healthcheck-0.3-4.module+el8.1.0+4098+f286395e.noarch


How reproducible: Always


Steps to Reproduce:
1. Install IPA server and ipa-healthcheck tool
2. Run ipactl stop
3. Now run the command 

[root@master ~]# ipa-healthcheck --source ipahealthcheck.meta.services --output-type=human

4. Check the message displayed on the console.

Actual results:
[root@master ~]# ipa-healthcheck --source ipahealthcheck.meta.services --output-type=human
SUCCESS: ipahealthcheck.meta.services.certmonger
20: ipahealthcheck.meta.services.dirsrv: dirsrv: not running
SUCCESS: ipahealthcheck.meta.services.gssproxy
20: ipahealthcheck.meta.services.httpd: httpd: not running
20: ipahealthcheck.meta.services.ipa_custodia: ipa-custodia: not running
20: ipahealthcheck.meta.services.ipa_dnskeysyncd: ipa-dnskeysyncd: not running
20: ipahealthcheck.meta.services.ipa_otpd: ipa-otpd: not running
20: ipahealthcheck.meta.services.kadmin: kadmin: not running
20: ipahealthcheck.meta.services.krb5kdc: krb5kdc: not running
20: ipahealthcheck.meta.services.named: named: not running
20: ipahealthcheck.meta.services.pki_tomcatd: pki_tomcatd: not running
20: ipahealthcheck.meta.services.sssd: sssd: not running

Expected results:
It should report ERROR for the services not running.

Additional info:

Comment 1 Rob Crittenden 2019-10-11 17:11:47 UTC
Merged upstream in master:
https://github.com/freeipa/freeipa-healthcheck/commit/28124d70d40c1cdd77eec46d8a547802eb2f9444

Comment 3 Sumedh Sidhaye 2020-02-11 18:25:57 UTC
Build used for verification:

[root@master ~]# rpm -q ipa-server ipa-healthcheck
ipa-server-4.8.4-4.module+el8.2.0+5591+1f878b19.x86_64
ipa-healthcheck-0.4-4.module+el8.2.0+5489+95477d9f.noarch
[root@master ~]#

Verification steps:
1. Install IPA server and ipa-healthcheck tool
2. Run ipactl stop
3. Now run the command 
ipa-healthcheck --source ipahealthcheck.meta.services --output-type=human
4. Check the message displayed on the console.

[root@master ~]# cat /etc/redhat-release
Red Hat Enterprise Linux release 8.2 Beta (Ootpa)

[root@master ~]# ipactl stop
Stopping ipa-otpd Service
Stopping pki-tomcatd Service
Stopping ipa-custodia Service
Stopping httpd Service
Stopping kadmin Service
Stopping krb5kdc Service
Stopping Directory Service
ipa: INFO: The ipactl command was successful
[root@vmaster ~]# ipa-healthcheck --source ipahealthcheck.meta.services --output-type=human
SUCCESS: ipahealthcheck.meta.services.certmonger
ERROR: ipahealthcheck.meta.services.dirsrv: dirsrv: not running
SUCCESS: ipahealthcheck.meta.services.gssproxy
ERROR: ipahealthcheck.meta.services.httpd: httpd: not running
ERROR: ipahealthcheck.meta.services.ipa_custodia: ipa-custodia: not running
ERROR: ipahealthcheck.meta.services.ipa_otpd: ipa-otpd: not running
ERROR: ipahealthcheck.meta.services.kadmin: kadmin: not running
ERROR: ipahealthcheck.meta.services.krb5kdc: krb5kdc: not running
ERROR: ipahealthcheck.meta.services.pki_tomcatd: pki_tomcatd: not running
SUCCESS: ipahealthcheck.meta.services.sssd


Based on the above observations marking Bugzilla verified.

Comment 4 Florence Blanc-Renaud 2020-03-21 08:39:34 UTC
Test added upstream in  ipatests/test_integration/test_ipahealthcheck.py::TestIpaHealthCheck::test_human_output

master:
https://pagure.io/freeipa/c/4a3b7baed785f7492e8404dac3eee8a8ce9fd937

Comment 5 Florence Blanc-Renaud 2020-03-23 08:17:42 UTC
upstream test:
ipa-4-8:
https://pagure.io/freeipa/c/7974ac9f8c7969df85f689d94f5b30c18e661daa

Comment 6 Sumedh Sidhaye 2020-04-21 14:32:39 UTC
Automated test passing in CI

------------------------------ Captured log call -------------------------------
transport.py               391 INFO     RUN ['systemctl', 'stop', 'sssd']
transport.py               513 DEBUG    RUN ['systemctl', 'stop', 'sssd']
transport.py               217 DEBUG    Exit code: 0
transport.py               391 INFO     RUN ['ipa-healthcheck', '--source', 'ipahealthcheck.meta.services', '--check', 'sssd', '--output-type', 'human']
transport.py               513 DEBUG    RUN ['ipa-healthcheck', '--source', 'ipahealthcheck.meta.services', '--check', 'sssd', '--output-type', 'human']
transport.py               558 DEBUG    ERROR: ipahealthcheck.meta.services.sssd: sssd: not running
transport.py               217 DEBUG    Exit code: 1
transport.py               391 INFO     RUN ['systemctl', 'start', 'sssd']
transport.py               513 DEBUG    RUN ['systemctl', 'start', 'sssd']
transport.py               217 DEBUG    Exit code: 0

Comment 8 errata-xmlrpc 2020-04-28 15:43:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1640


Note You need to log in before you can comment on or make changes to this bug.