Bug 175307 - Makefile.common ${DOCBASE}-$(1)/index.html incorrect handling of figs/
Makefile.common ${DOCBASE}-$(1)/index.html incorrect handling of figs/
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Wade
Tommy Reynolds
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-08 13:48 EST by James Laska
Modified: 2013-09-02 02:07 EDT (History)
4 users (show)

See Also:
Fixed In Version: CVS
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-10 22:26:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2005-12-08 13:48:57 EST
===================================================================
File: Makefile.common   Status: Up-to-date

   Working revision:    1.17
   Repository revision: 1.17    /cvs/docs/docs-common/Makefile.common,v
   Sticky Tag:          (none)
   Sticky Date:         (none)
   Sticky Options:      (none)


The current html_nochunk path does not properly copy over all images in figs/. 
The Makefile.common logic assumes all figs are in the figs/* directory.  For
several large documents we build, it is helpfull to seperate figs into
subdirectories by chapter (figs/ch-intro, figs/apx-1, etc...).  

The following patch resolves the issue, however it pulls in all figs which
appears to not be intended (don't want *.eps)?

Index: ../docs-common/Makefile.common
===================================================================
RCS file: /cvs/docs/docs-common/Makefile.common,v
retrieving revision 1.17
diff -u -u -r1.17 Makefile.common
--- ../docs-common/Makefile.common      2 Dec 2005 16:03:46 -0000       1.17
+++ ../docs-common/Makefile.common      8 Dec 2005 18:51:23 -0000
@@ -87,11 +87,7 @@
        cp ${HTMLCSS} $(DOCBASE)-$(1)/fedora.css
        cp ${HTMLCSSEXTRA} $(DOCBASE)-$(1)/
        [ ! -d figs ] || (                                              \
-               mkdir -p ${DOCBASE}-$(1)/figs;                          \
-               find figs -type f -iname '*.*' -print           |       \
-               egrep -vi '*.eps'                               |       \
-               egrep '(.*-$(1)..*)|([^-]*[.][^-]*)'            |       \
-               while read x; do cp -f $$$${x} ${DOCBASE}-$(1)/figs; done \
+               cp -a figs ${DOCBASE}-$(1)/figs;                                \
        ) && exit 0
 endef
 #
Comment 1 Tommy Reynolds 2005-12-10 22:26:16 EST
This code snippet is actually from the HTML "chunks" stanza; no figs/ copying is
done for the "nochunks" variant.

Added "docs-common/bin/copy-figs" shell script to copy the "figs"/ structure and
content.
Comment 2 eric@christensenplace.us 2009-07-07 00:09:27 EDT
Ticket moved to allow products to be removed from BZ.

Note You need to log in before you can comment on or make changes to this bug.