Bug 1753071 - Tests must allow skipping certain platform invariants to do node skew testing
Summary: Tests must allow skipping certain platform invariants to do node skew testing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Unknown
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.z
Assignee: Sudha Ponnaganti
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On: 1753070
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-18 02:36 UTC by Clayton Coleman
Modified: 2020-05-15 00:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1753070
Environment:
Last Closed: 2020-05-15 00:35:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 23821 'None' closed Bug 1753071: Allow certain tests to be skipped when performing skew testing 2020-05-14 23:52:23 UTC
Github openshift origin pull 23862 'None' closed Bug 1753071: Skip alert test when test environment is known to be skewed 2020-05-14 23:52:23 UTC
Red Hat Product Errata RHBA-2019:2856 None None None 2019-09-27 00:34:00 UTC

Description Clayton Coleman 2019-09-18 02:36:02 UTC
+++ This bug was initially created as a clone of Bug #1753070 +++

A 4.1 cluster test suite needs to be able to run against a 4.2 control plane with 4.1 nodes in a way that is reproducible for automation. For now, we'll create a "half" payload for 4.2 that excludes machine-config and then use the 4.1 suite. The test suite needs to ignore two specific tests that verify that every operator in the cluster has the same version (machine-config will be 4.1) and one that checks the images are all in the current payload.  That will enable the skew tests to use 4.1.

Fixing in 4.2 and then backporting to 4.1. It must be in 4.1 so we can run tests against master.

Comment 2 Clayton Coleman 2019-09-22 22:55:56 UTC
During investigation we identified a number of alerts that fire when a cluster is skewed that must also be skipped.

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-origin-installer-old-rhcos-e2e-aws-4.2/47

Comment 3 Anping Li 2019-09-24 11:09:16 UTC
@Jessica, QE don't know how to verify this bugs. Could you help us verify it?

Comment 4 Clayton Coleman 2019-09-25 15:49:41 UTC
Verification will have to be done by Jessica since she is familiar with the test infrastructure.

Comment 7 Clayton Coleman 2019-09-26 19:11:09 UTC
We had another fix, Jessica has to reverify.

Comment 8 errata-xmlrpc 2019-09-27 00:33:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2856

Comment 9 Clayton Coleman 2019-10-16 17:39:22 UTC
There was an additional fix required.


Note You need to log in before you can comment on or make changes to this bug.