Bug 175310 - Trying to create a new appointment in a non-writable calendar should warn you, rather than just silently being greyed out
Trying to create a new appointment in a non-writable calendar should warn you...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-08 14:10 EST by Suzanne Hillman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 15:10:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 324658 None None None Never

  None (edit)
Description Suzanne Hillman 2005-12-08 14:10:25 EST
Description of problem:
If one tried to create a new appointment with a non-writable calendar selected,
the new appointment dialog will pop up, but everything except the ability to
select a different calendar will be greyed out. It should tell you _why_ it's
greyed out, as one might not notice that it is.

Additionally, if one changes to an editable calendar, one should not be able to
go back to a non-editable one. (the option should be grey)

Version-Release number of selected component (if applicable):
evolution-2.0.2-25

How reproducible:
Always.

Steps to Reproduce:
1. Subscribe to a webcal
2. Select the webcal
3. Attempt to create a new appointment
  
Actual results:
Can't type anything; greyed out except for the calendar selection area.

Expected results:
Tell you why you can't type anything (or not allow one to try to create an
appointment while in a non-writable calendar, and give a dialog box saying why).

Additional info:
Comment 1 Dave Malcolm 2005-12-08 17:48:23 EST
Latest version of the code (tested with evolution-2.5.2-1) has a slightly
different layout that may be clearer.
Comment 2 Dave Malcolm 2005-12-20 19:02:48 EST
Confirmed with evolution-2.0.2-22 on i386 (vmware), and with rawhide.

(it picks the selected calendar as the calendar for the appointment/meeting)
Comment 3 Dave Malcolm 2005-12-20 19:19:34 EST
I've filed this upstream here: http://bugzilla.gnome.org/show_bug.cgi?id=324658
Comment 5 Matthew Barnes 2006-12-30 22:19:20 EST
The upstream bug report indicates the problem as been fixed and, indeed, when I
try to create an appointment in a read-only calendar using Evolution 2.8.0 in
RHEL-5, I get an error dialog that reads:

   Cannot create a new event

   You have a read-only calendar source selected. Change to Calendar View and 
   highlight a calendar that can accept appointments.

This bug was never proposed for a RHEL-4 update.  Is it alright to resolve this
as CURRENTRELEASE for RHEL-5?
Comment 6 Suzanne Hillman 2007-01-02 14:39:18 EST
As far as I'm concerned, closed CURRENTRELEASE for RHEL5 is fine.
Comment 7 Matthew Barnes 2007-01-02 15:10:30 EST
Thanks, closing as NEXTRELEASE since RHEL-5 hasn't quite shipped yet.

Note You need to log in before you can comment on or make changes to this bug.