Bug 1753124 - Example Report Query YAML lack of required fields
Summary: Example Report Query YAML lack of required fields
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.3.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-18 07:39 UTC by Yadan Pei
Modified: 2020-01-23 11:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Cause: Basic yaml example didn't have all required fields for Report Query. Consequence: When user attempted to create report query using basic yaml example, it resulted in error message Fix: Created a new yaml example specifically for Report Query which contains all required fields. Result: Example Report Query is created without any errors.
Clone Of:
Environment:
Last Closed: 2020-01-23 11:06:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2765 'None' 'closed' 'Bug 1753124: Example Report Query YAML lack of required fields' 2019-11-19 20:42:50 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:06:39 UTC

Description Yadan Pei 2019-09-18 07:39:16 UTC
Description of problem:
When user tries to create Report Query using example YAML, it will report error "spec.columns in body is required
spec.query in body is required" for field "[]"."
It would be good if we can add required fields in example YAML

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-09-17-001320

How reproducible:
Always

Steps to Reproduce:
1. cluster admin enable Metering
2. visit Chargeback -> Report Queries tab
3. click 'Create Report Query' button -> then Create

Actual results:
3. Error message returned:
An error occurred
Error "Invalid value: map[string]interface {}{"apiVersion":"metering.openshift.io/v1alpha1", "kind":"ReportQuery", "metadata":map[string]interface {}{"creationTimestamp":"2019-09-18T07:11:22Z", "generation":1, "name":"example", "namespace":"openshift-metering", "uid":"852a0c85-d9e3-11e9-b782-0050568b3449"}, "spec":map[string]interface {}{}}: validation failure list:
spec.columns in body is required
spec.query in body is required" for field "[]".

Expected results:
3. it would be good if we can add all required fields in default YAML

Additional info:

Comment 3 Peter Ruan 2019-10-25 22:31:09 UTC
verified on 4.2.2 stable image.

I can create a report using the example template.

Comment 5 errata-xmlrpc 2020-01-23 11:06:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.