Bug 1753128 - Cannot set MTU lower than 1280
Summary: Cannot set MTU lower than 1280
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.2
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1775136
TreeView+ depends on / blocked
 
Reported: 2019-09-18 07:50 UTC by Gris Ge
Modified: 2020-04-28 16:54 UTC (History)
11 users (show)

Fixed In Version: NetworkManager-1.22.0-0.1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1775136 (view as bug list)
Environment:
Last Closed: 2020-04-28 16:53:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
System logs with NM trace enabled (6.16 KB, text/plain)
2019-09-18 07:50 UTC, Gris Ge
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:53:59 UTC

Description Gris Ge 2019-09-18 07:50:56 UTC
Created attachment 1616113 [details]
System logs with NM trace enabled

Description of problem:

Cannot set `802-3-ethernet.mtu` lower than 1280, the network manager
will still activate the profile with 1280 MTU.

Version-Release number of selected component (if applicable):
NetworkManager-1.20.0-3.el8.x86_64

How reproducible:
100%

Steps to Reproduce:

#!/bin/bash
nmcli c del veth1
ip link del veth1
nmcli c del veth1

ip link add veth1 type veth peer name veth1.ep
ip link set veth1 up
ip link set veth1.ep up
nmcli device set veth1 managed yes

nmcli c add  type ethernet ifname veth1 \
    connection.id veth1 \
    ipv4.method disabled \
    802-3-ethernet.mtu 1200 \
    ipv6.method disabled
nmcli c up veth1
ip link show veth1

Actual results:

The MTU of veth1 show as 1280.

Expected results:

The MTU of veth1 show as 1200.

Additional info:

Comment 1 Beniamino Galvani 2019-09-18 09:05:38 UTC
Added a couple of commits to fix this to merge request

https://gitlab.freedesktop.org/NetworkManager/NetworkManager/merge_requests/273

Comment 3 Gris Ge 2019-10-15 12:02:26 UTC
This problem does not exists in NetworkManager-1.12.6-5.fc29.x86_64 of Fedora 29.

Regression it is.

Comment 5 Edward Haas 2019-11-18 14:11:42 UTC
RHV customers have the capability to set the MTU lower than 1280, so it is a regression if we do not fix it for RHEL 8.1.z
Could you please backport it?

Comment 8 sushil kulkarni 2019-11-18 16:09:03 UTC
Per comment c#5, requesting a z stream update for this. Will be required for RHV to pick up this change for their 4.4 release.

Anita, Can you please provide z stream+?

Thanks!
Sushil

Comment 12 errata-xmlrpc 2020-04-28 16:53:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.