Bug 1753234 - Enterprise Login (Kerberos) doesn't work with Samba AD
Summary: Enterprise Login (Kerberos) doesn't work with Samba AD
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-18 13:02 UTC by Alessio
Modified: 2019-12-04 19:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Alessio 2019-09-18 13:02:49 UTC
I was following this test case:
https://fedoraproject.org/wiki/QA:Testcase_Gnome_Online_Accounts_Add_Kerberos

I don't know if it is my fault or not.
The server is a Samba AD

If I use "kinit" from the command line, it works.

Using gnome-online-accounts when I insert the Principal: user@DOM.AIN and I hit Connect the password spoke appears. I insert the password and hit OK.
The Principal spoke go gray saying Connecting...
After some seconds I get: Error connecting to enterprise identity server: Timeout was reached.

If I hit Try Again, the spoke says Connecting... but it never end. If I hit Cancel, it does nothing. The window is stuck. I can click with the right button of the mouse and close the window.

And Enterprise login is in place.


Furthermore. If I delete the kerberos account, I reboot and I retry the operation. And when "Timeout was reached." instead of "Try Again" I hit Cancel, the window doesn't close.


Note You need to log in before you can comment on or make changes to this bug.