Bug 1753247 - Builder component should listen for SIGTERM
Summary: Builder component should listen for SIGTERM
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-18 13:26 UTC by Ryan Phillips
Modified: 2020-05-26 15:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-26 15:08:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift builder pull 101 None closed [4.3] Bug 1753247: listen for sigterm and terminate 2020-06-10 16:16:35 UTC

Description Ryan Phillips 2019-09-18 13:26:08 UTC
Description of problem:

Git clones are hanging for some reason. The builder tool should listen for a SIGTERM from kubernetes and not have to wait for the SIGKILL.

Related to: https://bugzilla.redhat.com/show_bug.cgi?id=1721847

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 16 Adam Kaplan 2020-05-26 15:08:26 UTC
Closing this bug due to current engineering priorities, severity, availability of suitable workarounds and lack of customer cases. If this should be addressed, please reopen and provide additional details.


Note You need to log in before you can comment on or make changes to this bug.