Bug 1753325 - [KeepassXC] QBasicAtomicInt::deref() (this=0x7fbe93ac1a80 <QListData::shared_null>) at /usr/include/QtCore/qatomic_x86_64.h:128
Summary: [KeepassXC] QBasicAtomicInt::deref() (this=0x7fbe93ac1a80 <QListData::shared_...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: keepassxc
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Germano Massullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1752993 1753088 1753339 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-18 15:22 UTC by ekulik
Modified: 2019-09-28 01:56 UTC (History)
9 users (show)

Fixed In Version: keepassxc-2.4.3-6.fc31 keepassxc-2.4.3-6.fc30 keepassxc-2.4.3-6.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 00:02:56 UTC
Type: Bug


Attachments (Terms of Use)

Description ekulik 2019-09-18 15:22:07 UTC
Description of problem: KeepassXC segfaults on startup


Version-Release number of selected component (if applicable): 2.4.3-5.fc31


How reproducible: Very


Steps to Reproduce:
1. Try to run the binary
2.
3.

Actual results: Segfault


Expected results: No segfault


Additional info:

Stack trace:

#0  0x00007fd47184248a in QList<QString>::detach_helper(int) () at /lib64/libquazip.so.1
#1  0x00007fd4603087de in GnomeHintsSettings::kvantumThemeForGtkTheme() const () at /usr/lib64/qt5/plugins/platformthemes/libqgnomeplatform.so
#2  0x00007fd46030d725 in GnomeHintsSettings::loadTheme() () at /usr/lib64/qt5/plugins/platformthemes/libqgnomeplatform.so
#3  0x00007fd46030dfdc in GnomeHintsSettings::GnomeHintsSettings() () at /usr/lib64/qt5/plugins/platformthemes/libqgnomeplatform.so
#4  0x00007fd460306cc0 in QGnomePlatformTheme::loadSettings() () at /usr/lib64/qt5/plugins/platformthemes/libqgnomeplatform.so
#5  0x00007fd460306d33 in QGnomePlatformTheme::QGnomePlatformTheme() () at /usr/lib64/qt5/plugins/platformthemes/libqgnomeplatform.so
#6  0x00007fd460306a0e in QGnomePlatformThemePlugin::create(QString const&, QStringList const&) () at /usr/lib64/qt5/plugins/platformthemes/libqgnomeplatform.so
#7  0x00007fd471a81419 in QPlatformTheme* qLoadPlugin<QPlatformTheme, QPlatformThemePlugin, QStringList&>(QFactoryLoader const*, QString const&, QStringList&) () at /lib64/libQt5Gui.so.5
#8  0x00007fd471a80db6 in QPlatformThemeFactory::create(QString const&, QString const&) () at /lib64/libQt5Gui.so.5
#9  0x00007fd471a89848 in QGuiApplicationPrivate::createPlatformIntegration() () at /lib64/libQt5Gui.so.5
#10 0x00007fd471a8aef8 in QGuiApplicationPrivate::createEventDispatcher() () at /lib64/libQt5Gui.so.5
#11 0x00007fd4714d70a5 in QCoreApplicationPrivate::init() () at /lib64/libQt5Core.so.5
#12 0x00007fd471a8c6b3 in QGuiApplicationPrivate::init() () at /lib64/libQt5Gui.so.5
#13 0x00007fd47202712d in QApplicationPrivate::init() () at /lib64/libQt5Widgets.so.5
#14 0x000055feed38bc89 in Application::Application(int&, char**) (this=0x7ffc2d0b0f70, argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/keepassxc-2.4.3-5.fc31.x86_64/src/gui/Application.cpp:50
#15 0x000055feed376431 in main(int, char**) (argc=<optimized out>, argv=0x7ffc2d0b11b8) at /usr/src/debug/keepassxc-2.4.3-5.fc31.x86_64/src/main.cpp:62

Comment 1 ekulik 2019-09-18 15:27:34 UTC
There we go, some more symbols:

#0  QBasicAtomicInt::deref() (this=0x7fbe93ac1a80 <QListData::shared_null>) at /usr/include/QtCore/qatomic_x86_64.h:128
#1  QList<QString>::detach_helper(int) (this=0x7fffedcdbf88, alloc=<optimized out>) at /usr/include/QtCore/qlist.h:718
#2  0x00007fbe828247de in QList<QString>::reserve(int) (alloc=1, this=0x7fffedcdbf88) at /usr/include/qt5/QtCore/qrefcount.h:102
#3  QList<QString>::QList(std::initializer_list<QString>) (args=..., this=0x7fffedcdbf88) at /usr/include/qt5/QtCore/qlist.h:165
#4  QStringList::QStringList(std::initializer_list<QString>) (args=..., this=0x7fffedcdbf88) at /usr/include/qt5/QtCore/qstringlist.h:110
#5  GnomeHintsSettings::kvantumThemeForGtkTheme() const (this=<optimized out>) at ../../common/gnomehintssettings.cpp:506
#6  0x00007fbe82829725 in GnomeHintsSettings::loadTheme() (this=0x562e3cc53c20) at ../../common/gnomehintssettings.cpp:333
#7  0x00007fbe82829fdc in GnomeHintsSettings::GnomeHintsSettings() (this=<optimized out>) at ../../common/gnomehintssettings.cpp:110
#8  0x00007fbe82822cc0 in QGnomePlatformTheme::loadSettings() (this=0x562e3cc33f20) at ../../theme/qgnomeplatformtheme.cpp:134
#9  0x00007fbe82822d33 in QGnomePlatformTheme::QGnomePlatformTheme() (this=0x562e3cc33f20) at ../../theme/qgnomeplatformtheme.cpp:40
#10 0x00007fbe82822a0e in QGnomePlatformThemePlugin::create(QString const&, QStringList const&) (this=<optimized out>, key=..., paramList=...) at ../../theme/platformplugin.cpp:27
#11 0x00007fbe93f9d419 in qLoadPlugin<QPlatformTheme, QPlatformThemePlugin, QStringList&>(QFactoryLoader const*, QString const&, QStringList&) (loader=0x7fbe943c7010 <(anonymous namespace)::Q_QGS_loader::innerFunction()::holder>, key=..., args#0=...) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:499
#12 0x00007fbe93f9cdb6 in QPlatformThemeFactory::create(QString const&, QString const&) (key=..., platformPluginPath=...) at kernel/qplatformthemefactory.cpp:51
#13 0x00007fbe93fa5848 in init_platform (argv=<optimized out>, argc=<optimized out>, platformThemeName=..., platformPluginPath=..., pluginNamesWithArguments=...) at kernel/qguiapplication.cpp:1247
#14 QGuiApplicationPrivate::createPlatformIntegration() (this=0x562e3caa64c0) at kernel/qguiapplication.cpp:1385
#15 0x00007fbe93fa6ef8 in QGuiApplicationPrivate::createEventDispatcher() (this=<optimized out>) at kernel/qguiapplication.cpp:1402
#16 0x00007fbe939f30a5 in QCoreApplicationPrivate::init() (this=this@entry=0x562e3caa64c0) at kernel/qcoreapplication.cpp:858
#17 0x00007fbe93fa86b3 in QGuiApplicationPrivate::init() (this=this@entry=0x562e3caa64c0) at kernel/qguiapplication.cpp:1431
#18 0x00007fbe9454312d in QApplicationPrivate::init() (this=0x562e3caa64c0) at kernel/qapplication.cpp:566
#19 0x0000562e3b29dc89 in Application::Application(int&, char**) (this=0x7fffedcdc750, argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/keepassxc-2.4.3-5.fc31.x86_64/src/gui/Application.cpp:50
#20 0x0000562e3b288431 in main(int, char**) (argc=<optimized out>, argv=0x7fffedcdc998) at /usr/src/debug/keepassxc-2.4.3-5.fc31.x86_64/src/main.cpp:62

Comment 2 Germano Massullo 2019-09-18 15:43:10 UTC
*** Bug 1753088 has been marked as a duplicate of this bug. ***

Comment 3 Germano Massullo 2019-09-18 15:58:38 UTC
*** Bug 1753339 has been marked as a duplicate of this bug. ***

Comment 4 Jan Grulich 2019-09-18 16:32:34 UTC
This is a weird crash. I can reproduce it, BUT I cannot reproduce it with the previous build (without quazip library support). There seem to be something wrong when using the quazip library. Also using QGnomePlatform with any other Qt application doesn't trigger the segfault.

I will try to investigate further.

Comment 5 Germano Massullo 2019-09-18 16:54:30 UTC
ernestask found out that quazip dependency should be replaced with quazip-qt5. I will try it in a few hours

Comment 6 ekulik 2019-09-18 18:01:56 UTC
Could it be because quazip from https://src.fedoraproject.org/rpms/quazip links against Qt 4?

Comment 7 ekulik 2019-09-18 18:04:37 UTC
┌[~/Development/github.com/keepassxreboot/keepassxc/_build] – (git) [develop*]
└[$] ldd ./src/keepassxc | grep Qt                                              ekulik@Whirlpool [2019-09-18 20:03:57]
	libQt5Svg.so.5 => /lib64/libQt5Svg.so.5 (0x00007f33697d6000)
	libQt5Concurrent.so.5 => /lib64/libQt5Concurrent.so.5 (0x00007f33697bd000)
	libQt5Network.so.5 => /lib64/libQt5Network.so.5 (0x00007f336956c000)
	libQt5Widgets.so.5 => /lib64/libQt5Widgets.so.5 (0x00007f3368ecc000)
	libQt5Gui.so.5 => /lib64/libQt5Gui.so.5 (0x00007f3368994000)
	libQt5DBus.so.5 => /lib64/libQt5DBus.so.5 (0x00007f33687a4000)
	libQt5Core.so.5 => /lib64/libQt5Core.so.5 (0x00007f3368287000)
	libQtCore.so.4 => /lib64/libQtCore.so.4 (0x00007f336748e000)

Comment 8 ekulik 2019-09-18 19:36:45 UTC
One of the KeepassXC developers told me that looking up the unversioned quazip so is intended due to $reasons. Best be hoping for Qt 4 disappearing from our lives soon.

Comment 9 Gwyn Ciesla 2019-09-19 13:49:39 UTC
I tried keepassxc-2.4.3-6.f31 and it works wonderfully. Please build for rawhide also and submit a bodhi update, and I'll provide karma.

Comment 10 Fedora Update System 2019-09-19 14:29:29 UTC
FEDORA-2019-c902ca4e32 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c902ca4e32

Comment 11 Fedora Update System 2019-09-19 14:29:36 UTC
FEDORA-2019-cbb3074eac has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-cbb3074eac

Comment 12 Vasil Velichkov 2019-09-19 15:54:36 UTC
*** Bug 1752993 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2019-09-20 01:56:56 UTC
keepassxc-2.4.3-6.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c902ca4e32

Comment 14 Fedora Update System 2019-09-20 02:56:53 UTC
keepassxc-2.4.3-6.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c93fc5bd3c

Comment 15 Fedora Update System 2019-09-20 03:02:01 UTC
keepassxc-2.4.3-6.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-cbb3074eac

Comment 16 Fedora Update System 2019-09-21 00:02:56 UTC
keepassxc-2.4.3-6.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2019-09-22 02:26:05 UTC
keepassxc-2.4.3-6.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2019-09-28 01:56:26 UTC
keepassxc-2.4.3-6.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.