Bug 1753355 - AllowVolumeExpansion is not set when upgrade from 4.1.z to 4.2
Summary: AllowVolumeExpansion is not set when upgrade from 4.1.z to 4.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Christian Huffman
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On: 1751641
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-18 16:44 UTC by Christian Huffman
Modified: 2019-12-11 22:36 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1751641
Environment:
Last Closed: 2019-12-11 22:36:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-storage-operator pull 48 'None' closed [release-4.2] Bug 1753355: Enables updating of StorageClass if a change is detected. 2020-01-23 17:48:42 UTC
Red Hat Product Errata RHBA-2019:4093 None None None 2019-12-11 22:36:16 UTC

Description Christian Huffman 2019-09-18 16:44:06 UTC
+++ This bug was initially created as a clone of Bug #1751641 +++

Description of problem:
AllowVolumeExpansion is not set when upgrade from 4.1.z to 4.2

Version-Release number of selected component (if applicable):
upgrade from 4.1.z to 4.2

How reproducible:
Always
Steps to Reproduce:
1.After upgrade from 4.1.6 to 4.2, clusteroperator is working
oc get clusteroperator
NAME                                       VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                             4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h27m
cloud-credential                           4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h45m
cluster-autoscaler                         4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h45m
console                                    4.2.0-0.nightly-2019-09-12-034447   True        False         False      41m
dns                                        4.1.15                              True        False         False      3h44m
image-registry                             4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h36m
ingress                                    4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h37m
insights                                   4.2.0-0.nightly-2019-09-12-034447   True        False         False      44m
kube-apiserver                             4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h42m
kube-controller-manager                    4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h44m
kube-scheduler                             4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h43m
machine-api                                4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h45m
machine-config                             4.1.15                              True        False         False      3h44m
marketplace                                4.1.15                              False       True          False      44m
monitoring                                 4.2.0-0.nightly-2019-09-12-034447   True        False         False      42m
network                                    4.1.15                              True        False         False      3h45m
node-tuning                                4.2.0-0.nightly-2019-09-12-034447   True        False         False      43m
openshift-apiserver                        4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h41m
openshift-controller-manager               4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h44m
openshift-samples                          4.2.0-0.nightly-2019-09-12-034447   True        False         False      44m
operator-lifecycle-manager                 4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h44m
operator-lifecycle-manager-catalog         4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h44m
operator-lifecycle-manager-packageserver   4.2.0-0.nightly-2019-09-12-034447   True        False         False      41m
service-ca                                 4.2.0-0.nightly-2019-09-12-034447   True        False         False      3h45m
service-catalog-apiserver                  4.2.0-0.nightly-2019-09-12-034447   True        False         False      105m
service-catalog-controller-manager         4.2.0-0.nightly-2019-09-12-034447   True        False         False      105m
storage                                    4.2.0-0.nightly-2019-09-12-034447   True        False         False      44m

2.Check storage class
oc describe sc
Name:                  gp2
IsDefaultClass:        Yes
Annotations:           storageclass.kubernetes.io/is-default-class=true
Provisioner:           kubernetes.io/aws-ebs
Parameters:            encrypted=true,type=gp2
AllowVolumeExpansion:  <unset>
MountOptions:          <none>
ReclaimPolicy:         Delete
VolumeBindingMode:     WaitForFirstConsumer
Events:                <none>


Actual results:
AllowVolumeExpansion is not set

Expected results:
AllowVolumeExpansion should be true
Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

--- Additional comment from Christian Huffman on 2019-09-12 18:04:36 UTC ---

I created https://github.com/openshift/cluster-storage-operator/pull/47 to address this issue. It examines the existing SC created from the assets file, and if changes are found in AllowVolumeExpansion or MountOptions these are applied to the existing SC.

--- Additional comment from Christian Huffman on 2019-09-18 15:14:08 UTC ---

For 4.2 this is being addressed via the documented in bug 1753311 . Moving this to target release 4.3.

Comment 1 Christian Huffman 2019-10-09 12:48:01 UTC
PR to backport this to 4.2.z has been submitted at https://github.com/openshift/cluster-storage-operator/pull/48 . This will be merged into the 4.2.z stream after 4.2 is released.

Comment 9 Chao Yang 2019-12-03 06:05:24 UTC
Verification is passed when upgrade from 4.1.0-0.nightly-2019-11-28-220857 to 4.2.0-0.nightly-2019-12-02-165545

Comment 11 errata-xmlrpc 2019-12-11 22:36:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4093


Note You need to log in before you can comment on or make changes to this bug.