Bug 1753394 - OLM Operator is showing wrong git commitId on 4.1.0-0.nightly-2019-09-18-141128
Summary: OLM Operator is showing wrong git commitId on 4.1.0-0.nightly-2019-09-18-141128
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.z
Assignee: Evan Cordell
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On: 1662263
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-18 19:23 UTC by Bruno Andrade
Modified: 2019-10-16 18:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 18:07:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3004 None None None 2019-10-16 18:08:09 UTC
Github operator-framework operator-lifecycle-manager pull 1044 None None None 2019-09-21 15:34:15 UTC

Description Bruno Andrade 2019-09-18 19:23:46 UTC
Description of problem:

There's a difference between what is shown on git commitId shown when executed from pod operator and from "oc adm release info"

Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-09-18-141128

How reproducible:
Always

Steps to Reproduce:

oc exec olm-operator-6854d7bc7d-nqsdw -n openshift-operator-lifecycle-manager -- olm -version
OLM version: 0.9.0
git commit: 51dcee9

oc exec packageserver-579ffbbd48-mf5sb -n openshift-operator-lifecycle-manager -- olm -version
OLM version: 0.9.0
git commit: 51dcee9


oc adm release info registry.svc.ci.openshift.org/ocp/release:4.1.0-0.nightly-2019-09-18-141128 --commits | grep operator-lifecycle-manager
  operator-lifecycle-manager                    https://github.com/operator-framework/operator-lifecycle-manager           2c174a6e4d9f9f10ba0c8a79725462efcf6b170

Actual results:
Difference between release info and operator info related to git commitId

Expected results:
Git CommitId should be equal from release info and OLM operator.

Comment 1 Dan Geoffroy 2019-09-19 13:08:43 UTC
This was fixed in 4.2 and needs to be reviewed as a possible backport to 4.1.z.  Moving target release for now until we can discuss backport.

Comment 5 Bruno Andrade 2019-09-27 22:28:21 UTC
Git CommitId is equal from release info and OLM operator as expected, marking as VERIFIED.

Steps used to reproduce:

oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-09-27-171543   True        False         94m     Cluster version is 4.1.0-0.nightly-2019-09-27-171543

oc adm release info registry.svc.ci.openshift.org/ocp/release:4.1.0-0.nightly-2019-09-27-171543 --commits | grep operator-lifecycle-manager
  operator-lifecycle-manager                    https://github.com/operator-framework/operator-lifecycle-manager           dacfea73a360acae43211efa95e7aa247f73b822

oc exec olm-operator-5bc5d5f7-mn76q -n openshift-operator-lifecycle-manager -- olm -version
OLM version: 0.9.0
git commit: dacfea73a360acae43211efa95e7aa247f73b822

Comment 7 errata-xmlrpc 2019-10-16 18:07:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3004


Note You need to log in before you can comment on or make changes to this bug.