Bug 17534 - pyton error in the installation script : "bad magic in header"
pyton error in the installation script : "bad magic in header"
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-15 02:00 EDT by Geert Jordaens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 14:53:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geert Jordaens 2000-09-15 02:00:08 EDT
When trying to install a RH6.2 via bootnet.img + updates 20000419. I get a
pyton error in the installation script : "bad magic in header"

my system : P133
SCSI controler : AHA 2940 UW
SCSI Disk : QUANTUM VIKKING II 4.5GB
Ethernet adapter : NE 2000 compatible


    def readHeaders(self):

        connected = 0
        while not connected:
            try:
                url = urllib.urlopen(self.baseUrl + "/RedHat/base/hdlist")
            except IOError, (errnum, msg):
#                print "IOError occurred, trying again"
                time.sleep(5)
            else:
                connected = 1
                
	raw = url.read(16)
	hl = []
	while (raw):
	    info = struct.unpack("iiii", raw)
	    magic1 = socket.ntohl(info[0]) & 0xffffffff
	    if (magic1 != 0x8eade801 or info[1]):
		raise TypeError, "bad magic in header"

	    il = socket.ntohl(info[2])
	    dl = socket.ntohl(info[3])
	    totalSize = il * 16 + dl;
	    hdrString = raw[8:] + url.read(totalSize)
	    hdr = rpm.headerLoad(hdrString)
	    hl.append(hdr)

	    raw = url.read(16)

	return HeaderList(hl)
Comment 1 Geert Jordaens 2000-09-20 04:28:14 EDT
This error occured as I was trying to install via HTTP. I had to instal via 
HTTP because it doesn't work via FTP. The mirrorsite I've used was :
mirrors.pandora.be/mirrors/ftp.redhat.com. 
It is possible that the mirrors site needs a user name and password and 
responds with on of the folowing codes : HTTP response codes: 301, 302 or 401. 
Comment 2 Michael Fulbright 2000-10-09 14:53:41 EDT
This seems to be related to the mirror site you were attempting to use - we have
not had problems with either FTP or HTTP base installs in our testing.

Note You need to log in before you can comment on or make changes to this bug.