Bug 1753418 - Plymouth bgrt theme paints update information as it has the wrong orientation and pitch
Summary: Plymouth bgrt theme paints update information as it has the wrong orientation...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-18 20:56 UTC by David Santamaría Rogado
Modified: 2019-11-18 01:17 UTC (History)
4 users (show)

Fixed In Version: plymouth-0.9.4-10.20191001gita8aad27.fc31 plymouth-0.9.4-11.20191022git32c097c.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-03 00:36:54 UTC
Type: Bug


Attachments (Terms of Use)
Plymouth update process (4.05 MB, image/jpeg)
2019-09-19 10:16 UTC, David Santamaría Rogado
no flags Details
Update process over console output (3.14 MB, image/jpeg)
2019-09-19 10:20 UTC, David Santamaría Rogado
no flags Details

Description David Santamaría Rogado 2019-09-18 20:56:55 UTC
I have recently updated to Fedora 31 through dnf update process. When the system restart plymouth is shown but then gets painted over all I suppose the update process letters as the efifb conseole before it was fixed by Hans.

Also when escaping from plymouth to the console output if the update text should cover the entire width of the screen it doesn't and only covers a square area from the left, as it will only write letter in the width as much as the ones that can fit in the height. Perhaps this second issue should be in another bug.

Have took photos if needed I attach them.

Comment 1 Hans de Goede 2019-09-18 21:05:58 UTC
Some pictures as well as info on the hardware you are using (Laptop vendor + model, graphics card, monitor/lcd panel manufacturer + model, etc.) would be useful.

Comment 2 Hans de Goede 2019-09-18 21:09:37 UTC
Ah I see that you are the reporter of bug 1730783, so I guess that you are seeing this on the Lenovo Idepad Miix 310 and/or on the D330 ?

And when did you see this, when going from F30 -> F31 through dnf-plugin-system-upgrade  ?

Comment 3 David Santamaría Rogado 2019-09-19 09:00:45 UTC
Yes, during the upgrade process after the reboot. It has been with the D330 but I suppose will also happen with the Miix 310. The 310 I will upgrade when the 31 final arrives.

Comment 4 Hans de Goede 2019-09-19 10:05:34 UTC
Ok, when I have some time I will try to reproduce this.

In the mean time can you upload the pictures you took as attachments here please?

Comment 5 David Santamaría Rogado 2019-09-19 10:16:18 UTC
Created attachment 1616666 [details]
Plymouth update process

Plymouth is shown as normal, then the update process starts and it get as shown.

Comment 6 David Santamaría Rogado 2019-09-19 10:20:31 UTC
Created attachment 1616667 [details]
Update process over console output

Here is the same update process just leaving plymouth on purpose. The max width allowed to write characters seems to be the same as the height. The output seems to be a square, just I don't know if the update counting should be all to the right. I remember in other computers without orientation quirks that yes but can't remember 100% sure.

Comment 7 Hans de Goede 2019-09-19 10:28:05 UTC
Thanks, I believe that the console output is normal, it just happens to look square, but it seems fine.

The gfx part OTOH of course is not good. I've done some quick checking and it looks like the text-renderer in plymouth does not take screen-rotation into account, so that will need to be fixed.

Comment 8 Hans de Goede 2019-09-20 12:50:31 UTC
Ok, so this reproduces on any device with a 90 degree rotated panel. I've submitted a fix for this upstream:

https://gitlab.freedesktop.org/plymouth/plymouth/merge_requests/66

I have some other plymouth issues which I'm working on. I will create updated Fedora packages when I've fixed the other issues. I will also add the fix for this issue to the Fedora pkgs then.

Comment 9 Fedora Update System 2019-10-01 11:57:51 UTC
FEDORA-2019-539bda477c has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-539bda477c

Comment 10 Fedora Update System 2019-10-02 15:53:17 UTC
plymouth-0.9.4-10.20191001gita8aad27.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-539bda477c

Comment 11 Fedora Update System 2019-10-03 00:36:54 UTC
plymouth-0.9.4-10.20191001gita8aad27.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 David Santamaría Rogado 2019-10-06 19:48:37 UTC
This is going also to be pushed to Fedora 30? Or is possible to install the 31 version over 30 fedora doing the upgrade process to test the bugfix?

Also from my absolute ignorance, it could not be possible to completely abstract the panel orientation from the kernel to avoid hacking over per display tool?

Comment 13 Hans de Goede 2019-10-06 20:23:07 UTC
(In reply to David Santamaría Rogado from comment #12)
> This is going also to be pushed to Fedora 30? Or is possible to install the
> 31 version over 30 fedora doing the upgrade process to test the bugfix?

I still have some other plymouth issues which I want to fix, want that is done I will also do a F30 update. In the mean time, you can do:

rpm -qa | grep plymouth

To see which plymouth packages you have installed, then download the F31 packages from here into a dir:
https://koji.fedoraproject.org/koji/buildinfo?buildID=1393022
(make sure you download the right architecture)

And then from the dir with the F31 packages run:

sudo rpm -Uvh plymouth*.rpm

To install the F31 version on F30.

Do not forget to regenerate your initrd after that by running:

sudo dracut -f

> Also from my absolute ignorance, it could not be possible to completely
> abstract the panel orientation from the kernel to avoid hacking over per
> display tool?

Unfortunately this cannot easily be hidden transparently in the kernel because hardware rotation with 90 degrees requires the framebuffer to be in a specific tiled format.

Comment 14 Fedora Update System 2019-10-23 09:28:48 UTC
FEDORA-2019-40dba3d36e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-40dba3d36e

Comment 15 Fedora Update System 2019-10-25 19:34:19 UTC
plymouth-0.9.4-11.20191022git32c097c.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-40dba3d36e

Comment 16 Fedora Update System 2019-11-18 01:17:27 UTC
plymouth-0.9.4-11.20191022git32c097c.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.